Unwanted scratching when nudging on jog wheel ring


TLDR: only nudging on jog wheel ring rewinds track (like scratching)

I’m curious if I’m the only one having this issue, couldn’t find any topics yet (I searched for “nudge” but maybe that’s not the right word for what I mean…) I’ll use nudge in this topic anyway :slight_smile:

When I’m trying to beat match and nudge the track back (or forth) a little, using the outside, metal-ish ring of the jog wheel (without touching the platter of course), it very often happens that the track rewinds as if I DID touch the platter, wanting to scratch.

If this happens live your pretty much f***ed!

I tried it many times, looking at my hand and focusing on NOT touching the platter, only the outside ring but it still happens…

Vinyl mode is on when this happens of course and I know that it won’t happen if it is off, but I want full control so I’m used to scratch and nudge having vinyl mode on, not toggling that button all the time. So I’m only touching the outside, metal-ish ring for nudging and I’m really touching the platter for scratching, setting cue points etc.

Does anyone have a solution for this or is this a hardware problem and do I have to return my Prime 4? :frowning:

Never had that issue before. I also do a lot of nudging my self but I normally touch out side the jog. As I feel the the touch platter is sensitive. I think there a setting to that am not sure doe. image

The prime series jogs are capacitive (touch sensitive) rather than mechanical and pressure sensitive like you would find on CDJ’s.

You need to move the outside of the jogs, not the platter or ring to nudge otherwise there is a very likely chance of the jog registering a touch.

I had this problem and was told it was a grounding issue on my SC5k…

I then remembered I had been given an EU power lead…swapped it to a UK one and it was solved

Nope never had

Yup, grounding issues (either that are related to the power grid/outlets/adapter or a rare hardware defect on the denon unit) result in screwed up touch sensitivity of touch capacitive jogwheels. Since SC5000 makes some kind of calibration on startup, poor grounding probably results in screwed up calibration making the unit detect touch when your hand is above the jogwheel.

1 Like

Okay thx! So how do I ground this thing? :sweat_smile:

It is grounded. But the outlets or some issue with the power distribution in the venue might be the cause.

Ran across this issue with the SC5000’s. Nothing a power conditioner and power isolation couldn’t fix.

1 Like

The provided AC cable is three pronged. The middle prong is the ground. Make sure the AC outlet is also three pronged and is correctly installed.


Thx for the replies guys! I’m on holiday now but I’ll check the power cables and AC outlet when I get back home :muscle:t2:

:+1: Enjoy your holiday.

Okay I found the problem. The power sockets in the wall aren’t grounded. My house is built in 1910… that’s why :smile: Possibly going to be some work to get them grounded I guess, but at least I know what it is now :muscle:t2: Thx everyone!

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.