Try to Update X1850 basically bricked mixer now

Tried to update to new version. Mixer stuck just running lights across. wont update or return to old update if tried. Too many problems with denon gear.

This might work for the X1850, but I doubt very much it is bricked, might just need some patience.

Too early to be spreading that nonsense

1 Like

In what state does it return after powercycle?

You might be able to do update step 2 only, if the mixer gets into “data receiving” mode.

Two things occurs.

  1. You can get back in to try and update it. Then it runs and says it is unsure if update worked and restart.

  2. No matter what if you restart all you get is lights in a wave motion across the mixer. They just repeat over and over.

At this point I can power down and try to get into the update status and then everything repeats. Tried a Mac update and then downloaded and ran update from windows pc with same problem.

Do any of your problems resemble this stuff I dealt with if you read through this thread starting here? If so, my method of resolving it might help you. Off the top of my head, the wave motion thing sound familiar.

This happened to me every time I update and downgrade firmware.

It took me 3 attempts each time to get the firmware into the mixer.

You’ll have to soldier it out and keep flashing until it goes through.

Do any of the different upgrade methods work better than others eg: usb stick rather than computer connection?

On the mixers? Where’s the USB A port you’re talking about that could be used for that purpose on the X18-- series?

On any all primes

I’m not aware of any USB A ports on the mixers or a process for updating them with a USB flash drive ‘stick’. The ‘sound card’ ports are USB B and used for connecting to a computer.

This topic is about an X18x0 mixer. Those don’t have ports to update via USB-flashdrives, so the question is off-topic.

As Wyley1 states, try to do this several times to get it into “data receiving” mode:

Hold BACK + FX CUE + TAP > Power ON

If you get this message, then start the updater again. Sometimes a re-seat of the cable triggers the next step. Also, you could try another USB port on your computer to force a successful connection.

I had this recently with my X1800 as well. It took 3 attempts…

1 Like

Still get the same problems. Doesn’t actually do anything control wise other than let me start the update and then runs through and stops responding. Then the process starts over. Tried handful of times today. Going to try tomorrow with a friends laptop and see what happens!

Have you tried installing the earlier firmware and then running the individual pieces in the directories on their own as I did in that thread? Obviously you’d be doing it with the X1850 firmwares.

X1850 doesn’t have 2 update parts in a directory. The X1800 does.

I finally was able to get the x1850 to take an update. I don’t know what it doesn’t like but was able to revert it to factory using a friends windows laptop. It wouldn’t take the newest version and would repeat the lock out. Once I put we got it back to factory, I was able to update it with a new Mac Book Pro that just came in. Very long week but she is on line.

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.