Traktor Pro Mapping file for the SC5000

Is there a way to use 4 decks in Traktor with 2 SC5000 players?

Why not? the Traktor Kontrol S4 only has 2 decks too (controlling 4 in the sw) and with a click of a button you switch to another deck. in the SC5000 case that should be the layer button. Just needs to be mapped the way you want it to work. I believe @NoiseRiser touched on this in one of his replies above as well.

1 Like

There is an option but not easy.

  1. Denon gives us an option to change the midi channel on the deck by hand.
  2. Very complex mapping (easy to have bugs) to control 4 decks from 2 players.

So far I build a mapping that can be used as 4 decks with one player or each player for one traktor deck. This mapping has most of the functionality and is tested and works stable with newest traktor.

I am in the making of a Prime 4 mapping as well. But this will take a bit time still.

1 Like

Thanks for your reply guys. I thought it would be a massive headache to get the mapping to work properly - having the layer just swap between deck 1 and 3 for one player and 2 and 4 for the other player.

Still though, the mapping is amazing @NoiseRiser - thanks so much for the hard work :slight_smile:

1 Like

Hi, is this thread still relevant a year later - or has there been an update since?

Bought a couple of SC5000s recently and I’m trying to configure Traktor so I can still use it - been a Traktor user for over 10 years and would like the ability to carry on using it.

I would appreciate a walk through of configuring if someone has time.

Many thanks

This mapping is not correct for traktor 3.

For most accurate mapping so far go here:

1 Like

Thank you, I’ll give it a whirl. :+1:t3:

1 Like

Ok so I downloaded and installed the .tsi file

<settings <controller manager <under device set up clicked add <scrolled down to import tsi <import other <located your file I downloaded <selected that as deck A <repeated the process but name that one as deck B

Assuming all this is correct? this is where I get stuck.

Under the In-Port Out-Port the SC5000s aren’t listed? What am I doing wrong please?

Are there any other settings that need changing?

I should mention, I am using and external mixer - a Traktor Z2.

Thank for the help.

You’re better off using timecode.

In absolute mode you can set hot cues and loops manually. However you can’t save the cues and loops.

Unless there’s hid or some kind of hybrid mode you will be wasting your time trying to figure it out. If it was working good for traktor it would be big news and you wouldn’t be here to query this :laughing:

You need to connect the sc5000’s to the computer via usb and set them in computer mode, this was rather obvious, so I didn’t mentioned it. When computer will see them as controllers then they will work.

@Wyley1 We all know that, thank You for giving in info, no one asked for instead of helping.

Thanks for your help NoiseRiser -

yes I have one of the SC5000s connected to my laptop via USB and the other linked with both set to computer mode but still Traktor doesn’t recognise them.

Thanks for your input Wyley, real helpful. Been using timecode for years but turntables are becoming rare in lots of bars and clubs where I am - besides I like having several options open to me.

What computer are You running? Mac or win?

MacBook Pro —

Check if macbook sees it in audio midi setup

Hi - I have been doing a few things to try and remedy this issue and have had some progress.

Firstly I used the USB 3.0 cable that came with the controllers rather than my own - think this was the issue as SC5000 now pop ups in my Traktor Controller Manager, In/Out Port list - awesome.

However, one controller lights up and has some control of Traktor software functions but the other controller has no lights as does nothing.

The controller that works is not configured correctly as the Loop Scrolling knob/Cue button is controlling both decks in Traktor even when Deck A & Deck B are selected under the separate .TSI files that were imported. The select knob is moving 5 tracks at a time when turned once and the play button doesn’t respond either.

Am I correct in assuming only one controller needs to be connected to the laptop and the the two controllers linked with the Ethernet cable?

Apologies for my lack of config understanding but it’s not something I do everyday.

Thanks for your assistance.

No, all decks need to be connected via usb.

Hi NoiseRiser,

The saga continues…

I’ve been trouble shooting this issue and I have been successful in getting one controller to work with Traktor perfectly.

The issues that I mentioned previously (playing both decks together) starts when I add in another .tsi file to the controller manager. It doesn’t seem to like two of the same file being in the device list.

I can switch the controller that works from deck A to deck B no problem just can’t seem to get both controllers playing the left and right decks.

I’ve tried duplicating the .tsi file I downloaded and adding that but I still get the same problems.

I feel I’m close to solving this but unsure about what to do next. Any ideas?

As always I appreciate the help.


When using 2 players You can use only one layer (one traktor deck) per player. When using more then one sc5000 player You are limited to use only one one traktor deck for each hardware. That depends on the deck focus in the controller manager.

Hi yeah thanks for replying - I am only trying to use two Traktor decks (A & B) with the two controllers but like I’ve described - one controller controls both decks when I add another .tsi file even when one is set to deck A and the other deck B.


You are having them only one deck selected as Your in and out midi ports