Tracks Wont Add To Playlist

Genuinely about to smash my laptop up at the moment. Im so sick of the ■■■■ from Denon and their shitty Engine Prime software. Its making my music damn near unplayable.

Ive got various music arranged in crates. I can play all the tracks, add cue points, loops etc etc. No problem. I can create new playlists. Can I add tracks to playlists though?! Can I f**k! Certain tracks just will not go into any playlists, new or existing. WHY WHY WHY?!

Honestly, it was only a few months ago that my Engine Prime DB corrupted and I had to start completely afresh with it. Ive got problems with the platters on my SC5000M players too. This is going to be the final straw if I cant get it sorted. Its all getting sold and Im off to boring but stable Pioneer. So sick of this ■■■■■■■■.

mind sharing one of the troublesome track?

Sure. How do you want me to get it to you?

  • wetransfer for large files or upload via PM (if its not larger than 20mb)

  • Just sent one PM to you btw

This is an example of one of many tracks that will not go into a playlist.

Works fine here.

So that rules out file issues.

And you are 100% sure the track has not been added already?

Maybe your database has problems.

1 Like

Absolutely, 100% sure. Ive even tried adding it to a brand new playlist that I created purely to rule out the old playlist.

Is there any way to test if the db has issues? Theres no way, NO WAY, Im going through setting everything up again in Engine Prime if the db has ballsed up again. That will be twice in 6 months which just isnt acceptable. If the db has gone wrong again, then thats the last straw for me - Im leaving the Denon fold.

1 Like
  1. Are you on windows or mac?

  2. Is the Engine Prime Collection internal or external HD

  3. Do you have your HOT CUES, LOOPS mirrored to another DJ Software?

1 - Windows 10

2 - Internal (but separate drive to OS)

3 - No, I generally dont use any other software. I do have Rekordbox for when playing on Pioneer gear, but I just export tracks etc as I need them in that and manually add hot cues and loops etc direct into Rekordbox

How is this second Internal drive formatted? NTFS?

I do back up to other programs intermittently…so if i have a db failure i can always convert back from my most recent conversion. But thats just me.

Almost gave up reading what with all the blocked out/banned words, all CAP shouters and disguised words.

Yes I can see, sort of, how a couple of tracks not being treated the same as 99% of other tracks could be a little bit frustrating but nothing to kick off so much about.

Anyway. In your screenshot of track listing it’s a pretty vague loose circle that’s been drawn in - are you trying to say the first track doesn’t behave? Or the 2nd track doesn’t behave? Or were you drawing attention to the first and second track? Or the first 5?

The second track looks like it could have some interesting things, file wise, which might (it’s a big might, but better than no leads or clue) be something.

Track two has a stray apostrophe in the field - it’s known that some special characters and those with grammar accents and odd characters outside of a-Z 0-9 can cause issues in any tag, even if not displayed. It might be worth editing any àäã etc back to an a and so on. Some video files have extra big album art, Again, might be worth stripping that off and adding a reasonable sized art instead. Track two is the longest track duration in the list - video takes up more file space than audio, so the longer the duration, the bigger the file. Maybe there’s some file size limit set, because of the file size limit of files being shared between decks on a separates SC prime system (ignore this file size thing on a prime4)

Track 2 is the first m4a file in that list (the track above is true audio). Although the primes do a clever trick with playing audio from a video file, video files have many different containers and a much wider scope of what codecs are deemed acceptable, than an audio file.

Is it only video files that are giving you trouble? Or at least video files with certain other criteria like tags, foreign chars, large art, file size etc ?

All TWO of them? rolls eyes OK then…

You wrongfully assume its “a couple of tracks”. Its hundreds of tracks actually and as this is just one in a long and growing line of issues Ive had with Denon and their software, then yes, it is something to kick off about I think.

The screenshot isnt mine. If you read the thread properly you’ll see it was from another user who asked me for a copy of one of the problematic tracks. Hes uploaded it into his Engine Prime, so you’ll have to direct all of those questions to him.

Nobody has mentioned video files. The m4a files were just some other files in the other users screenshot (not mine remember) that I have no control over.

All you said in your original post is “certain tracks” cause problems. How is anyone supposed to know it’s hundreds unless you actually tell us it’s hundreds?

You’ve not given any further details either.

1 Like

I’ll wait for further, more precise, more detailed and less impolite info then.

Although , really, you’ve already got your next step.

Rather than all the “I’m throwing it all out the window and going back to buying the rival”, look and read.

Other owners are doing what you want to do, they’re making playlists, adding all sorts of songs to those playlists and so on.

So the difference is, what have they got that’s different to you. Or what have you got that’s different to them.

Be specific. Rather than causing confusion by re-using someone else’s screen shot of songs you haven’t got, show your songs, specifically the song or songs that won’t add.

The screenshot is mine.

His track is the first track mp3

The m4a are not video files, they are ordinary audio tracks (AAC and ALAC are m4a)

Do you have any further suggestions for him?

[quote=“mufasa, post:15, topic:27248”] Do you have any further suggestions for him? [/]

Given the responses so far?

No as I think he has a fair few things to try out himself from the replies already given. Tags etc.

As the things he’s trying to do are actions which other people are doing successfully then it’s not going to be a problem that he can clear without some effort aka testing on his behalf. If it’s working for other people, then it’s not an instant “must be the firmware” thing.

I can see how it would be frustrating though.

@Christopia As mentioned twice now, the screen shot isnt mine so please stop saying it is. You’re making out like they are my tracks. As advised already, only the first track in the screen shot is mine and I sent it to @mufasa so he could test loading it into a playlist. The other comments you made about tags etc all refer to the other tracks in the screenshot which are nothing to do with me, the issue Im having, my playslists or anything else described in this post. Id really suggest you read through this whole thread again so you can get a true picture of whats going on before commenting with any further suggestions.

Rather than getting defensive, don’t you think it would be more useful to post some more detailed info?

Your lack of info is what caused the misunderstanding in the first place.

More succinct info is what’s needed here.

Show us an existing playlist that works

Show us a track which successfully adds to that list

Show us a track which doesn’t add to that list

Show us that “won’t add” track playing successfully on its own outside of a playlist

Show us what happens when that track doesn’t add - like an error message, a red flash, a warning sound, a reboot of windows

Narrow down the numbers. Saying you’ve got hundreds of tracks which won’t add seems far-fetched. Would someone sit and try adding just track 1, oh didn’t work… try adding just track 2, oh didn’t work … try adding just track 596, oh didn’t work. If you multi select a few hundred tracks and 1 track in that selection is problematic, it could stop the entire selection from adding , until the problem track is deselected and the mass add tried again.

Don’t get half way into something then go into unrelated things - like a squeaky platter is not going to have anything to do with playlist track adding - by all means mention any other probs but keep each story separate and not cross contaminate

Also gross exaggeration won’t help either so saying “ Its making my music damn near unplayable.” when the issue is only that you’ve got some tracks which won’t add to a playlist are nowhere near accurate.

We’ll all try and help when the right info is clearly given - and that hasn’t been the case so far - sorry

I’ve had this happen to me a few times using different songs all mp3’s in 320 using Windows 10 and latest Prime (stable) and beta.

Not sure why it intermittently refuses to accept a new track when you drag the file from the crate and drop it into a playlist, but once it does it will never accept it. The only way I’ve managed to work around it is to delete the playlist and create a new one, this has worked most of the time.

The other times it’s happened I’ve had to delete my collection, import them again and re analyse the collection.

I can’t find any rhyme or reason to why it does and it’s never the same songs so I’m assuming it’s a glitch somewhere. The songs themselves actually play fine, I can edit beat grids, loops, hot cues etc

I’ve also tried the beta version and it happened last night to me.

Frustrating yes, end of the world no. Denon’s software it’s under constant review and I think all constructive feedback will help eliminate these niggles.

Sorry I can’t give any definitive reason or explanation, when it’s happened to me it’s been completely random.