Trackpad Scrolling in Mac Ventura Buggy

I’m having an issue when scrolling through the library on my Macbook Air M1 (Ventura 13.3.1) with the built in trackpad (also happens with Magic Trackpad) where the library will scroll as expected, then jump back some number of tracks (8 tracks?) and continue scrolling. If I scroll very slowly it doesn’t display this behavior, but if I quickly scroll it happens every time.

Not sure if this also happens with a mouse as I don’t have one handy.

1 Like

For information, it is still happening in 3.1.1.

Ive tried replicating this on my M1 MBP and cant… do you have any 3rd party mouse drivers installed or anything outside the normal Apple apps, better touch tool etc?

I don’t. I should have clarified in the initial post, but this is happening when “two finger scrolling” on the trackpad.

1 Like

Yeah that’s exactly what I was doing… what about other apps open at the same time?

Only Chrome.

I’m trying to attach a screen recording hosted on dropbox but it doesn’t seem to be working.

Here’s a YT link.

Only thing I can suggest is close all programs down, reboot then re-open just Engine and see if it’s still happening.

Thanks for the thoughts. It happens on a fresh reboot without anything else running.

Sorry, I’ll have to let someone else jump in to assist if that hasn’t solved.

Only thing different for me is im on Ventura 3.5 and the new 3.2.0 Engine version.

I’ll try the OSX update. I can’t seem to find the 3.2 Engine to download?

It’s linked in the 3.2 announcement post, not on the site at present I don’t think.


Ah. Thanks. Found it.

1 Like

NP, hopefully it sorts the issue out for you. I’ve had a problem with the software popping up when using other apps which I reported.

I can confirm that it still happens with Engine DJ 3.2 and Venture 13.5.

It happens on the “release” of the scroll, not when the fingers are actually scrolling on the pad. It stays consistent when the fingers are scrolling and only glitches when the fingers leave the pad and the “momentum” of the scroll continues.

1 Like

Just tried that and still no joy replicating from my end.

@STU-C , this is the same issue we were discussing a few days ago.

it’s something to do with the event handling and inertial scroll of the buffered views.

@brianr , i’m sure if you have enough playlists, you can do the same thing with the tree view on the left. This has been an issue for me for quite some time as posted here on March 2022: Tree and listview scroll logic is off (stutters with trackpad + inertial scroll)

Yes!!! I was just sitting here trying to figure out how best to describe the scrolling issue in the grid view and make another video and post. I’m having that problem as well. It seems to jump back to one of the prior hot cue points. Super annoying.

yes, it’s specifically an issue with slow scrolling or gentle “nudging”.

The issue may actually be with Qt itself (the underlying UI Framework).

1 Like

I managed to get it happening on my computer, it seemed to me that doing it on smaller playlists (where the scroll bar was around 1 inch in size) was the easiest way to trigger it. Previously I’d been using longer playlists and it wasn’t happening.

Not sure if this could make a difference to your testing. I’ll do some more today and also fire my mouse up to see if it happens when scrolling with that too.