Timecode file waveform changes after loading into sc6000m?

I am using Traktor with timecode and sc6000m. I don’t have a mixer with built in effects and this will allow to utilise effects via traktor software, otherwise i would play the files directly.

However whenever i scratch and change pitch on the sc6000m there is low input error messages and issues with the timecode (in traktor).

I have ripped my own timecode files from CD to WAV file and also downloaded ones available online, the same issue arises.

I just realised that the waveform differs when I look at the timecode file a lot of the audio detail is whitewashed. No wonder there are issues in tracking etc.

Is there anything that the sc6000m might do which alters the waveform? Perhaps a frequency limitation?

I have reviewed the same audio file in traktor and the full waveform detail is visible. For some reason the detailed audio information seems to be missing from the sc6000m? Any ideas or advice?

See image link: https://ibb.co/8BsWNsR

Would much appreciate any construction assistance or advice.

Did you try with key lock off?


Keylock off and on the picture we can see you are not using timecode file as wav but as mp3 so that also may cause a problem.

Thanks @mufasa and @SlayForMoney , key lock off helped to solve the pitch control.

I’ve gone back to the Wav file and the result is the same.

Compared with a normal music file the difference is significant.

Also compared with the same file in Traktor you can see that the file appears to have been changed by the SC6000m.

Someone mentioned it could be auto gain.

Is it possible to lock a file down from autogain? I haven’t used the Denon Prime software as yet and i think I need to do that now.

what’s wrong with the wave form?

Does it affect playback?

I think what is happening is that the SC6000m is altering the wav/mp3. You see all the white block in the wave form? That should be timecode wave detail.

With this loss in timecode detail, the effect is that is I am getting a low timecode signal in Traktor.

The waveform has been auto-gained (or somehow altered) as you can see the difference between how it looks in the sc6000M and traktor.

The sc6000m version appears to be much “louder” but part of the audio detail appears to have lost. This is just my theory.

@mufasa I could be completely wrong about this, its just a theory.

Auto gain (if that is actually happening) is removing some of the detail of the timecode WAV/mp3, this leads to low timecode error when I am scratching and changing pitch.

Alternatively, maybe I ripped the timecode improperly meaning some of the timecode information is lost from the CDrip.

I am not aware of autogain in the primes, infact there is a thread requesting autogain on the forum.

@NoiseRiser uses traktor maybe he can shed some light

Primes have no autogain - not possible in the process where players and mixer are separate devices. Autogain information is stored in the file if You use Traktor. The process of autogain in traktor is only a change of volume, no audio information is lost. When using a limiter - you can cut off some dynamics - that will alter your audio information.

Don’t expect the timecode waveform to look like normal audio (music) because it’s not.

It’s just a single very high pitched “note”, so because the Denon waveforms are divided into low/mid/high colours, it makes sense that you see one big block of white - because that’s what the sound consists of.

Just to confirm - you are using Traktor timecode, yes? Only you mentioned downloading them and from what I can see they aren’t available to download.

@PKtheDJ he ripped them

Traktor timecode is downloadable via native access for licence holders.

When ripping uncheck normalizers, volume levellers, etc.

Hi @NoiseRiser I don’t profess to know anything about Prime hardware/software, but i did notice that the timecode track when first imported to Prime is very small looking or “quiet”: timecode import

However following analysis in Prime, the timecode track is much bigger “louder”:

Post analysis

I cannot seem any zoom or scale in Prime, so I assume it has been auto-gained by Prime because the volume of timecode is very low compared to a standard music track.

I still theorise that the track is autogained, because post analysis the waveform looks completely different to the same file viewed in traktor. For want of a better description, the waveform has been visually stretched or autogained significantly.

(note that the process above is of the mp3 version of the timecode as I had forgotten to screen shot the process with my WAV file - which I did first. But what I observed was identical across both versions.)

On the basis of this observation, I decided to try something, I took my ripped timecode WAV and imported into Audacity and manually amplified the track and then used this directly in the sc6000m.

With this amplified WAV, there is zero “low quality timecode” error message appearing in traktor. Scratching works perfectly and no other issues arise. In short this has been the solution for me.

I used EAC to rip the timecode CD to WAV, and its been a long time since I’ve ripped CDs to WAV/FLAC files, but it is unlikely yet possible it could’ve been a ripping error resulting in the timecode WAV being far too quiet thus causing my original issues.

Thanks for your input, fingers crossed the sc5000/6000s get officially supported in traktor as HID devices one day - saw your work on a tsi for the sc5000m.

@PKtheDJ thanks for clarifying that, I was wondering just exactly how much audio detail was likely in a timecode file.

To answer your question, I first ripped my own timecode from the original CDs which came with my Z2 mixer, but when i was trying to isolate the problem I also tested “freely” available downloads of the MK2 timecode in mp3 form.

@Wyley1 if I’m not mistaken NI used to allow downloads of earlier timecode versions, but do not offer a download for the MK2 timecode.

I have not been able to find any in my NI account/product download libraries, and would appreciate if you could direct me to any official timecode download.

All tracks do that, start small while the analysis is taking place, then expand to full the screen once the analysis is complete. It’s nothing to do with normalising, it’s simply resource saving (I’d assume).

  1. Engine Prime, Rekordbox - has 3 band waveform

  2. It has nothing to do with autogain or normalizing

  3. Its only showing the same information in a different way

  4. I downloaded the mk2 timecode and loaded it into rekordbox



as you can see the 3 band style waveform looks fatter than the regular RGB style. Its just cosmetic.

@yeltsin, ok then its purely a visual thing, but the issue was a overly quiet timecode track, that needed amplification.

@mufasa Thanks for that, indeed it does “look” fatter in RGB across the same scale.

This is how it looks in Traktor DJ as well.

but the issue was a overly quiet timecode track, that needed amplification

Turn up the gain on the mixer

1 Like

I’m playing around with my sc5000m and Traktor timecode now.

This is the basic setup, 1 sc5000m and an akai amx.

And here’s what I see

Works like it should so far with good tracking on the scope.

What mixer/sound card are you using?

I’m not sure that I can gain the timecode I don’t think, I have a Native Instruments Z2 mixer with built in audio interface and when using the mixer as a DVS for traktor, the gain controls on the mixer become midi interface for gain on the tracking playing in traktor.

@Wyley1 thanks for posting, I’ll have a look in couple days when I can get infront of my gear. I am using a Native Instruments Z2 mixer. Timecode works fine when just playing a track but when scratching or even just changing pitch it spits out “low quality timecode signal errors”.

This has all been solved by making the timecode track “louder” however.

That’s all it could be as moving a file around from crate to crate or drive to drive won’t re-write the file itself.