Sync Manager loses all playlist structure and makes one big collection

When I use sync manager with a new freshly formatted exfat SD card, none of the playlist structures are carried over, and all the songs are just dumped into one big collection. I’ve tried several dif cards, and even single playlists, but the same error happens. Even reinstalled Engine. No clue how this is happening.

3 Likes

Folder structure in exported media will not be the same as playlist structure in engine DJ. If you navigate by playlists in your player the playlists show up?

Nope, they don’t. One big pile of music. And the Playlist structure in Engine DJ has always duplicated to my SD cards when I’ve used the sync manager, so this is totally a bug.

Just be glad you didn’t lose the entire collection, as Engine DJ likes to do. I had imported 5,200 tracks of my collection and it disappeared. All back-up, internal hard drive, and external hard drive info. gone.

People actually try and use sync manager?

same problem here. after export. no playlist. tracks are exported but not in a playlist

1 Like

Experiencing the same bug here - but never had this issue previously. Currently having to use an old USB until this is fixed and unable to update my portable library - has anyone got a fix for this yet or heard anything from Denon as per what is causing this?

Here’s the jerry-rigged workaround. I had 4 SD cards of which only 1 still showed playlists after mistakenly trying to sync the other 3. I took the one SD card that worked still, and copied it’s “Engine Library” to my desktop. I then replaced the 3 Engine Library files on the non working SD cards and that’s what replaced the playlist structure. The Sync Manager is the cause so avoid using it. Just drag your items over individually. Denon should look into what happened with the 2.3 upgrades to the sync manager, because that is where the break happened.

1 Like

feels like a major bug in 2.3 lets hope Denon will fx this asap.

Having this issue along 2 other DJs I know. This is actually really dealbreaking. After sync is completed the files are on transfered, but not the actual playlist information. it’s one huge collection without playlists.

Is there any way we can help debug this? logs? whatever?

This is actually a HUGE bug that needs attention ASAP :heart: