Sweep FX in headphones only

I purchased a Prime Go so I could practice and work out mixes and sets wherever I am but the one thing that doesn’t seem to work in the headphones is the SWEEP FX buttons which is essential for me.

These buttons work fine when the Prime is plugged into speakers in the master or booth but not when listen through the headphones.

Should this work? If so is there a setting I need to apply?


Same in Prime 4

Why would they do that, makes no sense? Surely you want to check an effect you want to use in the headphone and see how it works on the track before you mix it in!

I think it’s a bug or “Denon state of the art feature”. Just one more of many. On my Prime 4, only “filter” and “noise” effect sounds trought headphones.

IMHO Engine prime at this time is a B-Class product, needs so much improvement to take it seriously to be used more than in house parties.

You don’t happened to have the headphone Cue button on? I can hear my sweepeffects when I only use the headphones at home which is nice.

To clarify: On my Prime 4, only “filter” and “noise” effect sounds trought headphones when cueing any of the 4 channels. Sweep and echo effects doesn’t apply on cue audio routing.

I’m about to buy a Prime Go and tried all three Prime devices in a shop today and the Prime Go and Prime 2 didn’t have any of the FX in the headphones, but with the Prime 4 it was working which doesn’t make sense to me at all. Can anyone from Denon could advise on this, is this normal or is this due to firmware or updates issues? THX

After update to 2.0 I can confirm all 4 effects on filter knot now are routed to headphones audio when cueing channel is on (Prime 4)

Seems they resolved this strange bug.

But I found new one related to effects after 5 minutes playing with new firmware. If you change effect to the next or previous one while is on, and turn on again, plays the old effect, not the new one. Confirmed on Flange effect comming back from auto gate.

1 Like

Yes I experienced the same issue when I tried the prime 4 with the effects coming back to old one, the prime go wasn’t updated with the latest firmware when I tried it so this might be now resolved… I’ll let you know when I try the update on the prime go. Thanks @Obocaman


Echo and Sweep only sounds trought headphone while channel fader is UP. If you down your fader, effects fade out from headphones. So the bug persists at least on Prime4. Sorry

1 Like

So this has not been fixed yet. How can that be? This is the most glaring error ever, and I can’t for the life of me understand how a product can be released in this state.

Very poor quality control I think. I found that “bug” on firsts 5 minutes playing with my new unit … and so many updates later still there.

If it’s a planned behavior not make sense to me.

I didn’t seen on any competitors devices that sweep fx would go directly to headphones… So this behavior is following the industry standard so far…

What industry standard?? :rofl::rofl::rofl: Explain all of us about that industry standard where half of effects are routed to CUE “only when fader is up” and not the other ones.

If Denon makes a mixer where two of four channels sounds trough a highpass filter by default… for all Denon fanboys (that includes you) should be industry standard. :man_facepalming:t2:

Don’t judge me if You don’t know me. Check other gear, as I said. The Color fx on djm mixers is behaving the same.


Name me one product where the sweep filter isn’t audible through the headphones. Cause I don’t know any.

Absolutely awful.

I hate the fact you cannot hear fx sounds in your headphone cue, every other dj software I’ve used, you can tailor this to your preference.

The amount of times I’ve moved the fader up, only to hear the bloody fx through the master is annoying ! :angry:

Just to be clear, Denon standalone products dont run with DJ software, so not sure where your comment is directed at? this is firmware.

What is Engine O.S then ! ?

Not something that powers any hardware, its a music preparation software that bears no relation to how hardware works, or how effects are routed through that hardware.

As @NoiseRiser stated above, its completely normal for these hardware effects not to be heard through headphones, as evidenced on ‘industry standard’ Dj mixers.

Ive done it plenty of times at gigs using Pioneer Nexus equipment, left the effect parameter enabled and had to turn it off mid mix because i didnt realise.

Certainly not a ‘Denon’ issue by any stretch.