Strange behaviour with waveforms after latest update

Backround: Newbie with Sc Live 4

Workflow: My whole collection is located in usb stick, arranged in genre folders, and subfolders with full albums and one folder per genre for various stuff. I have then selected all the folders in windows file explorer and dragged them to “collection” in Engine dj desktop. This means that my folder structure matches my playlist structure. This has served me well for 6 months. I now have my first gig coming and i’am trying to create a playlist for that specific event.

Problem 1: When i browse thru the main playlist AND load a song (for preview etc) in a deck (in desktop engine) and then drag it to the “event specific” playlist, the waveform changes: White spikes get taller, meaning there somehow is more high frequency “data”. As if the song is somehow doubled. After that, the selection (from right click menu) no longer contains re-analyze option. It might be my imagination, but it also sounds like crap after that, bass is weak and vocals too hot. I don’t thinks its actually duplicating the file, and that wouldn’t be what I’am after… i just need the option for the same song to be shown in multiple playlists.

Seems like a bug to me, but might have something to do with my workflow?

Problem 2: The white cue mark (indicating song start) is not located in the beginning of the waveform in several songs. It is about 1 second after (to the right) the song actually starts. Funny thing is that i can not move it to the beginning of the wave, i can move it 1 second before it (leading to short silent period). As if the actual beginning is “write protected”.

Problem 3: Bbm readings are false in some songs. E.g many songs in Scooter first two albums are shown to be 70-80 bbm, and we all know that’s not correct =)

Any ideas/similar issues?

On your first issue. Can you explain further, is this ‘USB Stick’ the only place you keep music? And you use it for both library management and performing with?

If so that’s not the correct way to keep your music, you have no backup for a start. You should ideally have your base collection on the computer hard drive or some other connected drive… then only export to your performance drive using sync manager, creating 2 copies of your music essentially.

Re-analyse doesn’t work when you’re viewing music in the ‘drives’ part of the software. Have a look on YouTube on the engine dj channel for guides on how to prepare and export music.

Your second issue is likely down to your beat grid position, the number 1 on the beat grid should be in the same place you want your white cue marker…. The reason it’s not going where you want it to is likely to be because you have Quantise active, meaning it’ll only snap to the beat grid, in whatever multiple you have quantise set to…. Either turn it off or align your grid accurately.

1 Like

Try these videos

Thanks for reply!

Yes, i have no music in my computer, but i have two copies of the usb stick/drive.

Reason for this is to have my whole collection with me all the time + 1 usb is connected to my wifi router for listening through ”hi-fi” equipment.

For the re-analyzing, i’m not in the drives section, its in the main view song list when a playlist is selected. and the option is there for all the other songs, not for those having the issue with changed waveform.

I”ll try to remove the quantazing option, thanks!

1 Like

Right I get you now, the only thing I can suggest is removing the impacted files and re-loading them. Are your databases and firmware versions all up to date for both desktop and device?

1 Like

I will re-import my whole library.

Could someone try if you can replicate this?

Just to rule out something is wrong in my settings etc…

Just open playlist A and load a song in engine dj’s deck and play it

After that drag the song to playlist B, and see of the waveform changes in the preview window (before the song name in playlist view)


I’ll try it out this afternoon to see. I don’t have tracks in multiple playlists at present so it should be easy to replicate the scenario

Edit: I cant replicate this, tried playing several tracks and adding them to a new playlist and it won’t do it.

maybe try recording your screen to show the issue in a video so people can see it.

Ok, thanks for trying!

Just to be sure, you couldnt add same song to two playlists at all? Or it did not do anything to the waveform?

You cannot re-analyze while a track is loaded to a deck.

The waveform change might be the small GUI aid to see the change when gridding or editing bpm.

If your whole collection is on the external drive, like mine is as well, try to work from the drives section. Especially for smart lists. They’re bound to drives.

1 Like

I added it to a new playlist and nothing happened to the waveform, it just kept playing.

1 Like

Thanks for replies!

I took a video of the problem. Before that i deleted engine database and only worked with one Scooter album, which i drag to “collection” in the beginning of the video.

The video clearly shows, that if i move a song to a playlist without it being loaded to a deck, nothing happens to the waveform.

If i first load it to a deck and then add to playlist, the waveform changes. In the video, I also load the song to another deck, after the “waveform” change, so you can see it in happen in the deck as well.

What you don’t see in the video, is that the right click menu has less options for the files that have this “waveform” change. Both in the new and the original “source” playlist.

video: removed

You can also see the false Bbm:s + the cue mark being in wrong place?

I took the video down.

i guess the easy workaround is to not load the songs into decks when creating new playlists. Instead you can listen them from the original playlist directly.

DenonDJ staff should still investigate this, as this clearly is a bug of some sort.

Bpm problem was solved as well. I changed the range as i have more uptempo songs in my collection. Maybe the system could give some kind of notification if analyzed songs are “out of bounds”.

Thanks Stu-c And Reese

1 Like

The waveform resizing is something I’ve seen since about version 2.7. I just shrugged it off as it wasn’t something that really hampers performance though it can be jarring to see. ¯_(ツ)_/¯