Soundswitch / Engine Lighting "ignoring" crossfader off on Prime Go

So the new Engine Lighting feature got me interested in trying SoundSwitch. I just got the mini DMX interface a couple of days ago and have been messing around setting it up and thought I was missing something obvious, and I kind of was, but I think it’s a bug personally.

I was testing with the Prime Go, set up my lights in SS on the laptop, got it all working, exported everything to SD, stuck it in the Prime Go, enabled lighting, and no matter what I tried I was getting nothing from my lights outside of the overrides

I’ve finally just figured it out - every track I was testing I was loading to deck 1. I randomly decided to try deck 2 and it worked immediately. Some further investigation later and I’ve figured out that, despite me having my crossfader disabled in the settings, SS is very much using it even though it’s not impacting my audio due to being switched off!

Fine I thought, I can just leave the crossfader in the middle and if it gets knocked I’ll realise quickly by the lack of light and can put it back…alas it’s not that simple as SS/Engine Lighting set the brightness of the lights based on how far up the channel faders are AND on the crossfader position. Therefore, even with crossfader turned off, it needs to be fully left for deck 1’s lighting to be at full brightness, and likewise with deck 2. Leave it in the middle and light scripting/auto loops work from both decks, but at a maximum of half brightness.

Am I missing something here as a very new Soundswitch user or is this a bug?

That still seems to be a bug in Lighting.

You can set the performance menu in SW Desktop: Upfader only - i.e. without blend mode. But it only works with network cable and SW desktop.

But not with PrimeGo via lighting

1 Like

OK, thanks…as you probably guessed, the whole reason I looked at SS was because I was already not using a laptop for audio and now hoping not to use one for lighting either. I still have an old myDMX installation on my laptop which I’ll maybe revert to until this is fixed.

It’s fixed with Update 2.02.

Nice work



Ah! Great! Thanks for letting me know…you’ve saved me some work as I was planning to check that this evening!

Great work from the Denon team, thank you.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.