Sound Forge 18 with denon X1800 mixer

I am trying to record a mix from my Denon x1800 to my Sound Forge 18 application and for the life of me I cant get it to meter in any way. I have made sure the sample rate is the same but I just can get it to record. Its so weird as I can get it done on the soundforge 10 but not the new version which I would like to use. Any help would be appreciated.

I’m not familiar with SoundForge, but did you check if you have the correct input-channel chosen from the x1800? If I’m not mistaken, it’s sending out audio via USB on channel 9/10 per default, unless set to “Broadcast-mode”, so this could be it :blush:

1 Like

Thank you for the response. I have played around with those and I just can’t get any signal for some reason. I used to use an older version of sound forge and it picked it up no problems.

I use Sony Sound Forge when I want to record hires over ASIO and I’m not streaming.

Lately, though, I mostly just record 16/48 in OBS while I’m streaming, as trying to record in Sound Forge and stream at the same time is glitchy. I also have it set up to record as it goes in case OBS crashes or I get BSOD.

Anyway, go to Options, Preferences, Audio, and Record tab.

Then choose the source you want. If you’re using ASIO and the X1800 drivers, you don’t have to use Broadcast Mode on the mixer. Apply.

Click the record red circle symbol and make sure the bit depth and rate are all correct (you may need to create a new window under File otherwise), then click the Monitor checkbox.

Now you need to click the channels on the right side and select the ones you want for the stereo pair. If you use Broadcast Mode, I suppose that last step would probably be unnecessary. I have not bothered with Broadcast Mode, and I believe it was added for software like Audacity. Even in OBS I use ASIO, I think with a plugin I downloaded way back.

1 Like

Honestly thank you for taking the time. Soundforge 10 works perfectly but im struggling to make Soundforge 18 work. The above looks eaxctly like SF10 but SF18 is a bit dofferent but you have given me and idea. I will play around with it tonight and will let you know. Again thank you

All good I have finally worked it out… thanks for all your help.

1 Like

Can you explain what exactly the issue was and how you resolved it, in case some of us upgrade to the newer versions later?

1 Like

I really not 100% sure but I think I changed the default setting to stereo and it seemed to work: