Sound break up/stutters/speeds up

The sound breaks up and stutters, sometimes speeding up. sometimes, I am able to get it to run through a set without this problem, after I’ve rebooted the program or switched my controller off and on again. the problem in the past would randomly occur out of no where during the set. but more recently, just at the beginning. I’ve had this problem ever since I first bought mc7000 about 8 months ago and i’m fed up with it. it happens on my PC and also on a brand new, completely clean windows 10 thinkpad Lenovo 8gb ram intel core i5 8th gen 1.6ghz I bought at the same time of buying the controller! I’ve tried everything to try and fix this… even spent £20 on better quality usb connector. it must be your mc7000 driver that’s at fault. Can you please fix the bug and update the driver. Thanks. Any other suggestion? using Serato DJ pro 2.1.1

1 Like

Hi @god7000 and I’m sorry to hear you are having this problem.

Could you please contact our support team who will be able to assist with this:

Regards J

Hi @god7000,

Sorry to hear of the troubles with the MC7000. I can attest to the product, I’ve been using the MC7000 for 2 years with over 100 events in, no audio issues what so ever. So it may be a simple setting on your setup or the hardware itself. Could you answer the following questions?

Does the stuttering sound happen immediately or after some time playing?

Have you tried to adjust the buffer settings in Serato Dj?

Does you computer have USB port support a low power mode that it could be entering after a certain time period?

Moving out of Bug Report section as this is not a bug but a support case.

Hi @god7000 - can you please PM me your email address and I will follow this up today.

Hi J, Firstly, I messaged technical support on the link you gave. still no answer after 3 days. When you say the hardware itself, do you mean the Laptop/PC I’m using for the MC7000 or the MC7000 itself?

  1. After i’ve installed the latest driver firmware some months ago, the sound break up has only occurred at the start of a set, shortly after first track is played. Basically when I start using it. Most times after rebooting or restarting the MC7000 it can be fine through an entire set, no problem. Other times, the problem doesn’t occur at all. Attached is the .wav file of the fault I managed to record, shortly after starting my first track mc7000error … .wav (2.1 MB)
  2. I have tried adjusting the buffer settings on Serato from 256 to 512 (5m/s to 10m/s) but still happens. Is it the lowering of this number or increasing it, that’s makes it more likely for the fault to occur?
  3. As far as I know my Thinkpad E580 laptop does not have a ‘low power mode’. How do I find out for sure? I have followed the instructions on the Serato website on how to optimised you PC, and have put all the power saving modes to zero etc. The laptop I bought was recommended for DJ’s and cost around £700. it was brand new 64 bit windows 10 8gb ram etc. in fact Serato and the MC7000 driver were the first things to be loaded onto it. you do not expect this to happen. I also had the same issue when connecting my MC7000 to my old PC. Could it be the hardware settings on the MC7000 itself? I recently came across the hardware settings pdf file in the firmware driver files. Could changing the default ‘4’ number on the MIDI Command Transmission Interval Time setting make any difference? if so, is it better to increase or decrease this number? Thanks Tim

Thank you very much for this thorough response, could you please email this directly to our uk support who will response today:

Thanks J

Thanks Jay, for that email address. I will use it if I continue to have issues. However over the weekend I’ve done some more investigating after @JWiLL questions/pointers. it may have nothing to do with the MC7000 or its driver at all. Changing the buffer settings or the MC7000 ‘MIDI Command Transmission Interval Time’ hardware settings doesn’t appear to have made any difference. Although the question about USB low power did get me thinking. I did check this. its called USB selective suspend setting in win 10 power options and it was already disabled on my laptop. But I wonder if the problem is to do with power issues (or a lack of) or maybe even spikes in the electricity supply. I tended to have the mc7000 on first, then boot up my laptop with it plugged into the mains adapter and load up Serato straight away and get straight on with trying to play a track when this problem occurs. So instead I tried starting up MC7000, booting up laptop and running it off just the battery. Allow a few mins for the windows to load up and settle down plus the Serato software. Then after a while… play my first track. so far so good!
I’ve ordered another UK spare power adapter for mc7000 just in case its that. I thought I would post this in detail in case others have the same issue. It may not be an issue with this controller at all but can be vulnerable (like all sensitive low power USB devices are) to USB power supply issues, esp when your PC is busy? Is something like that plausible? I will post again if this proves not to be the case. Thanks, Tim

Thank you for the update Tim and good to hear we’re on the road to get you sorted.

Keep us posted!


Hi @Jay_DenonDJ , I’m also having this same issue since switching from Mac to Windows. What was the fix?

1 Like

Wow, Denon, do you even offer support to your customers? I’ve sent in three support requests now over two weeks for this issue and had no replies there or on here.

Paste from another thread i just replied too. This is nothing to do with Denon. Its Serato and Win10. Just see the Hundreds of threads on Serato forums about it…

Fix…>>> I assume this is with Serato ?. Serato and Windows 10 is just horrible. There is a real issue with the sound sub-system and time duration. These threads are very popular over on Serato forums. There is no issue with the mc7000 itself.

Fix: Install Windows 7 as a dual boot. Then you have a clean OS to use just for DJ work. Thats what i have. Serato works perfectly in Win7. No freezing, no sound issues. Just reliability. I do Club sets, and a FM Radio show so cannot have my laptop freezing on me. I know people with MACs that have freezing issues too. But Win7 is just perfect.

I’m also having this problem. I cannot find the solution anywhere. Any updates?

The latency setting on the laptop must be increased.

The laptop is too busy with other processes in the behind the scenes to make the audio work smoothly.

Increasing and maybe doubling the latency setting on the laptop should reduce or stop the odd noises

Thanks, but the latency now is 256 If I adjust to 512 I think the sound is bad. Isn’t it?

The higher the latency number you set, the better the sound becomes

But the laptop will respond to button presses slightly slower.

That’s the trade off

You think it is? Have you tried it?

Where did you read / hear that the sound will be bad if you set the buffer size to 512?

The adjustment is there for a reason. The correct setting is the one that works well with your computer. If your computer needs the setting at 512 to work well, that is the correct setting for you.

512 should still give you around 10ms latency, which should not cause problems.

If you’re using VDJ, set the latency via config to zero, otherwise it will not allow you to adjust via the Pioneer driver util.