Some Tracks Not Found on Players

I’m having an issue where tracks that are not red and play fine in Engine DJ software on my laptop, show up as red and not found/playable. Another strange thing I’ve noticed is that some tracks that are red and not found/playable on one linked player, will be found/playable on another linked player, and vice versa. Any ideas why this might happen and how to fix this?

Check the filenames. E.g., while the Mac Engine DJ desktop accepts filenames with odd characters (such as "/ colon) they are not compatible with exFat and the players.

Don’t know why they would read on some players.

Also, I did have a case where a purchased aiff played fine on the desktop, but the SC6000 refused to load it. I re-wrote the file with XLD (aiff->aiff) and it then worked.


The only thing I can suggest is formatting your drive then re-exporting all your music to it, which will create a new db file too.

Could it have been an AIF file? that needed to be AIFF? I seem to recall some issues with those where it was one and not the other.

I’ve tried formatting new drive and copying the same music to it. Didn’t help. Issue(s) persist.

Most of my files are AIF and AIFF files. They both work fine in most cases. Can you elaborate on issues with these? Thanks :pray:t2:

I will try re-encoding to see if it does anything. Thanks for the suggestion.

Hopefully one of the more techie people will be able to elaborate but I’m sure one of the formats is notoriously bad for not being read by certain media players. I think AIFF is the valid one.

See if you can notice a pattern whereby one or the other are the tracks that don’t show.

Edit: forget that, ive just tested on my own and both AIF and AIFF are seen in the app.

I believe aif and aiff works without issues

As suggested by @androphonic

  1. check the file names of the red tracks for non English characters

  2. If you find any remove them from main collection,

  3. then rename the files,

  4. then add them to collection again.

  5. Then export them to performance drive again using sync manager

1 Like

If you want to preserve your beatgrid and cues you don’t have to remove the track(s) from the collection. You will have to fix them one by one. Rename the file to remove the offending characters. In Engine DJ desktop they will now be red. Right-click and choose the relocate missing file option. Manually relocate the file. It’s pretty easy because it opens the folder where the file is located for your choice. It will warn you the name doesn’t match, but proceed.

Yes, aif and aiff both play fine on my units. Technically aif and aiff files are the same per what I read. There are mysteries though. A while back Ableton Live was writing aif for me that would not hold ID3 data. I had to convert those files to get them to hold those data. Ableton Live seems to have corrected that in a later update.

1 Like

Funny you should say that, I recently made an edit in Logic and after exporting I think I had similar issues with AIF, I think it also wouldn’t play in Apple Music and only worked in Quicktime.

It’s definitely got something funky about it.

Yup; The ones that are red are a mixture of both AIF and AIFF. So that’s not it.

The offending tracks don’t have any foreign or incompatible characters, and as previously stated, some of these tracks will show up and are playable on one player, but not another (linked) player. The issue is definitely with the software somehow and not the files.

What about re-analysing all your tracks? does that help?

Tried that. Doesn’t help.

Send one of the offending tracks via PM

Will do. Thanks for the assistance.

Another strange thing I forgot to mention…

If I connect to my computer and load my playlists from it (engine) via wifi, all the offending tracks appear and play fine on the players.

I noticed something with the tracks in question: It seems that the folders that contain the ones I’ve checked so far end with (1998) etc… So maybe the parentheses has something to do with it.

EDIT: I figured out my issue; the offending tracks were nested in folders that had a space at the end of the folder name. That’s it. Removed the space(s), and everything is back to normal. Sad that a stupid thing like this could cause this in hardware running Engine (SC5000 and Mixstream Pro tested). Not the case with Rekordbox.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.