Serato issues and controller not working

Bought this controller today and cannot get it to work. Says it is connected and streaming but will not control anything. Meanwhile in Serato it is giving me a broken down version and says I need to upgrade or purchase a license. This should have come out of box with full version.

Windows 7 user. Help!

Since you don’t mention it, I have to ask. Did you install the Windows driver for the 7000?

You can find the latest one here: under downloads (scroll down a bit).

As for Serato, when you open it, does is say MC7000 connected somewhere at the bottom?

follow these steps

Thanks for responding. I did install the driver and in Serato it invites me to connect a controller, even though the Denon app says it is connected and streaming.

Have loaded it all up onto a Mac this morning and all worked perfectly.

The above eliminates faulty cable etc. So my issue I think is a windows setting issue that the pc sees the hardware but is not letting it talk to Serato.

Appreciated. Did find something similar and think did most of these. Will take time tomorrow to check through and see if it solves.

Seen how it works on my mac and happy with product so keen to solve.

Have you tried disabling or uninstalling any webcams on the laptop

I don’t use the webcam but it does have an integral one - I will try and see if that works. Thanks.

Hi all. I’m having a smiliar problem as well. I can control the equalisers and gains but that’s all. I’m on windows too. Mapped it more than 10 times to make sure. Got Traktor and Serato. Can anyone help?

Not sure this will be much of a help…Denon were helpful but did not solve. Serato were slow but eventually got a guy on phone and he could not solve. Did everything they asked several times but nothing.

So in the end took my laptop to local pc shop and had windows reinstalled. Wasn’t that expensive and solved whatever was getting in the way of everything communicating. Been perfect ever since.

Use Serato 2.0.5, not the latest 2.1 which has about a million bugs and runs so slow its not usable.

Ive got this exact same issue, was working perfect, nothing works on screen, volumes do adjust but show no change on screen, latest drivers installed. Its almost like the mapping has vanished.

Using 2.0.5 and latest drivers