SC5000 Play/pause not responding


I have a problem with my Denon SC5000. Sometimes the Play/Payse button does not respond, the track seems frozen. This often happens when I try to start a song with the jogwheel : when I release it the song doesn’t start even if the play mode is on. Then the play button doesn’t work for few seconds. I have taken a video to show the problem : - YouTube

Thank you very much for your help :pray:

Hello @Reuil, Welcome to the forum. As I told You on Facebook already, this has nothing to do with the play button. You can clearly see the jog is reading a touch (white light on the jog). This is known and its due to bad grounding (electrical grounding). You need to check with another power source (different room, house) to see if it gets better. If not then the jog is too sensitive. Don’t touch the jog wheel during player startup as it is calibrating the touch sensitivity then.

Thank you for your answer. I’m locked down in a different house than mine, but the problem has been present in both houses. I’ll be careful not to touch the jogwheel during the startup, but if the problem persists what else could I do ? I don’t have any bill of the player because I bought it from second hand. The warranty could work anyway ?

Thank you for your help

The insufficient ground problem usually only occurs as a premature trigger as your hand nears the platter when the unit is ungrounded. Simply not putting the hand OVER the jog when you’re in an ungrounded venue and bending should be enough to mitigate it to use the units. The issue with the random flicker appears related to some kind of internal contact issue of the jogs completely unrelated to your power outlet grounding. You might want to try physically reseating the jog in the spindle and see if that helps. Also, make sure you also touch the back grounding screw to see if that improves the situation or not. If it doesn’t, then it’s also not the electrical plug. Obviously make sure the film is off the platter. And lastly, don’t forget to try disabling vinyl mode to see if it goes away. Some people have stutter issues with playback in early firmwares that’s not touch. Hopefully InMusic will lengthen the minimum time the ring goes white in future firmwares so we can better narrow down when this happens and what’s causing it, because sometimes it does flicker too fast quite to see.

This is not the ground problem. I had the same issue (and also the ground problem), so I started looking for a grounding problem and it turned out my condo had an issue with one of the phases of its 3-phase power supply. With that fixed, I found I still got this problem of trying to drop a track and the deck freezing and the play button not responding. It seemed to be intermittent but was getting worse so I decided to take my deck apart since I live in Malaysia and can’t easily send it for repair.

Firstly, I couldn’t find anything online that mentioned how to remove the platter. For anyone interested, you need to undo A LOT of screws to open the deck up, and I found that the 6 larger screws underneath, as I undid them the plastic inside cracked on 2-3 of them so they cannot be re-assembled. This is poor material strength around the injection moulded base part. The design really needs more meat on it to prevent this happening. I glued 2 of them back together but the third was trashed.

After that, I wasn’t sure what to remove, so I disassembled the entire deck and all of the PCBs looking for access to the jog wheel. To access it, you need to undo the large nut in the centre (which is glued in position too), once this is off you need a pair of circlip pliers to remove the circlip so you can push the whole rotating axle through the bearing to allow the platter to come out.

Onto the source of the problem.

The computer knows the position of the jog wheel thanks to a trigger wheel - a translucent disc with a lot of black lines around it. This passes through a laser which counts the beam breaking lines to understand rotation. I found that part of the disc had been contaminated with white dust, obscuring the laser and presumably causing it to lose track of its position and freeze the deck. The source of the dust was obvious, and reveals a rather dumb design. It comes from the plastic brake shoe that is used to create resistance on the platter (the one you can adjust tension of from the knob on the deck). I run mine on around half resistance so there could have been a lot more friction, but even with my setting the brake shoe had worn against the platter and ground around 0.5mm from its surface which had turned to white plastic dust which was found all around the area. Since I transport my decks quite often on their side in a travel case, the dust had migrated around the void and found its way onto the encoder disc, slowly causing it to lose function.

A pretty easy fix - clean off all of the dust, turn the deck to no resistance setting unless you want the problem to re-occur, then re-assemble. A word of warning - I put the platter in 180 degrees and found out later that the screen is now upside down - DOH! Can’t be arsed to take it all apart again for that though. It is now totally fixed and works better than it has in many months. Which is amazing, but I must say that is a pretty crap design and the resistance mechanism in general needs a complete rethink. I hope they revised it heavily for the SC6000.


As soon as you mentioned white dust I had a hunch that’s what it was from. Wow.

So what were your symptoms? Was it the weird random platter flickering and touch activating?

That sounds more like the ground problem to me. The grounding problem was a hyper sensitive capacitive touch sensor which would detect your fingers well before they touched the platter, and sometimes would flicker on and off. This could be solved by turning off vinyl mode and deactivating the touch sensor.

The dust problem is where the platter doesn’t respond to turning, either partially or completely. So you would go to drop a tune and it might respond while you’re moving the platter in large movements to find the cue point, but when moving slowly to drop the tune, it loses position and the tune stops completely and won’t respond even though the play button is pressed.

1 Like

Different. As I said previously, there’s a very rapid platter activation thing that happens totally independent of where your hand is or if the AC outlet is grounded. Reseating the platter seems to help it.

From your description, I have not experienced this turning detection problem from the brake dust yet. My brakes are all the way down or slightly up to simply make the resistance similar between the players. I prefer loose platters, but one or two of my three non-Ms were not as loose as the other(s). One platter was stuck when it first arrived and never quite as loose as the others… had to be pushed down or something if I recall. It was a replacement from InMusic for another unit that died.

So there are at least three distinct platter problems that appear to be physical issues.

Hmm yeah maybe there are 3 distinct issues then. Yours sounds like it’s a problem with the capacitive sensor but maybe not related to grounding - maybe a bad connection - broken wire or bad solder?

I suspect it’s some sort of issue with a connection in the spindle itself, but it’s hard to say. It’s not just one unit that’s done it, though. This is very distinct from the predictable grounding problem that, IMO, is rather easy to deal with by simply jog-bending without putting your palm over the platter. I never even bothered turning the touch off when in venues without grounding.

I had the same problem,

I fixed it though Sick_nimpson post. But instead I stopped at the part with the glued nut.

I took the vacuum cleaner and put it on the hole of the laser that passes though the encoder (which counts the beam breaking lines). I spined the deck slowly ones while vacuum-cleaning and assembled everything again.

It works :smiley:

1 Like