SC5000 intermittently dropping network connection on one player

Hello All,

I have interesting intermittent issue with my SC5000 players and X1800 mixer. Player 1 appears to intermittently drop it’s network connection when the USB is plugged into Player 2. When I plug the USB drive into player 2, player 2 recognizes the USB, and I select the drive which then loads the music, que points, etc. without issue. At the same time, Player 1 recognizes the drive, I select it, and usually is then stalls out, and usually drops the network connection. Player 2 is unaffected, and remains connected to the network.

Note: this only occurs to player 1. Player 2 is unaffected and never drops it’s connection. Networking diagram: Household wired connection: Router (ASUS RT-AX55 router) to a dumb 8 port switch, to the X1800 Hub (PC port), Port 2 is for Player 1, Port 3 is for Player 2.

Power-on sequence: Power-on the X1800 first and let complete it’s bootup. Player 1 powered next, wait 10 seconds, and power-on Player 2. (this power-on sequence seems to allow for smoother network connections/stability)

Insert drive into player 2 (Both Front and rear ports have been tested). Usually the problem arises at this point.

I have tried different network cables (the ones currently used are brand new). I have even tried direct connecting the players to each other using Player 2’s known good cable (although, direct connecting does not resolve the issue, in fact, the players have never connected in this manner, yet).

USB thumb drives tested: Kingston Datatraveller 100 G3 32GB and a Kingston DT50 16GB.

IP’s: release/renew on the X1800 don’t seem to force the reconnect on Player 1. Player 2 has zero issues reconnecting. The X1800 is showing an IP address of 169.254.. (I dont recall the last 2 values) showing that it isn’t pulling a DHCP IP from my router, so it’s creating it’s own internal network.

Firmware: both SC5000 are current on1.6.2 and the X1800 is current on 1.5 and hardware 1.0 (updated yesterday).

Of note: If I power on the units, and put the USB into player 1 (front or rear USB ports); it generally is more stable, it sometimes will drop the connection (but it is less likely). (Like today it survived for about 2 hours, then dropped the network on player 1 - player 2 network remained connected).

Edit to add additional testing: Tried rolling Player 1 back to 1.5.2 and PC update (via USB cable) to 1.6.2. No change, Player 1 still drops the network. Rolled both players back to 1.5.2. Same network dropping issue. Further, Player 2 recognizes updates are available. Player 1 does not. Tried plugging the 2 SC5000’s into my dumb switch. They recognized each other, pulled DHCP addresses (I could ping them) but once I plugged the USB in, Player 1 dumped it’s network connection.

I am thinking Player 1’s network device is faulty (but it could be something else I am not aware of)

Help? Please? My thanks, Niteshade

1 Like

Have exactly the same problem: Same equipment, same Firmwares. @ Player 1 (left side) where i hooked my SSD starts and mount the SSD fawlessly, and Player 2 (right side) looses his Network connection from time to time, and only on Player 2 too…

So, is it a Hardware problem or Firmware ?

Thanks, hope i get a Information!

regards, Roland

Or the cable

I’ve had this problem ever since the WiFi was opened, but unfortunately it was out of warranty. I’d send it back if yours is, as it’s not getting fixed by any amount of firmware updates, it’s a faulty wireless NIC. Mine does work perfectly when wired into the mixer, and WiFi is turned off, so no major issue for me at home.

Ref the network cable: As detailed in my testing (and post): I tried different network cables to rule that out.

Ref Faulty NIC: You’re likely right? I wound up returning the unit under my extended warranty and they replaced it.

To DJProsac - Likely Hardware - Faulty NIC methinks. Return the unit for repair/exchange. There’s nothing we can do on our end from what I can gather.

To everyone: Here is a Video of it is misbehaving:

Hey @Niteshade - Many apologies for the issues you’re facing. This seems like a situation best suited for technical support to get involved. Can you DM me your phone number, email, and full name so that I can forward you over to the team. They’ll be able to help you more efficiently with direct contact.

No need, and no worries - The problem has been resolved through my local dealer (fortunately, and their warranty program). Just surprised it took 30+ days to get traction on this issue).

1 Like

Tbf that can’t be blamed on Denon, should always have been via the retailer (certainly in the U.K. anyway).

I’m not blaming Denon, or anyone. My initial post was to see if there was a user level workaround/solution or to determine if I was all screwed up somewhere in my setup/usage.

Fortunately, my extended warranty saved the day (Buy these if they are available from your gear supplier! - they sometimes come in handy) - so all in all, it all came out clean in the wash.


1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.