SC5000 Black screen after updating

Hi all, Greetings from London/UK. :hugs:

I need some help, please! :pray:t2:

My DENON SC5000 Prime updated itself automatically via WiFi and after rebooting the screen is just black, nothing comes up, all buttons remain lighted up (see pic 1).

Also, after the update, the on/off button at the back can only be used to power the unit up, the only way to turn it off is by unplugging the cable.

I have tried to reset it by pressing the combination EJECT+SOURCE+LAYER and then powering on. - but when I do that it lights up the round screen in the middle of wheel (stuck on it), nothing else happens (see pic 2). Ps. My laptop is not recognizing the unit anymore.

Any help would be much appreciated. Thanks in advance. :pray:t2: @djalkans

Hey @Adriano_Santos - Can you try the following…

  1. Manually put the unit into update mode → EJECT+SOURCE+LAYER + Power On (At this point your screen may still be dark but the unit should still be in update mode)
  2. Update the unit via USB cable and computer (Downloads here Desktop and OS Downloads + Manuals | Engine DJ)

Please let us know if this fixes your issue.



Thank you for your assistance, I am unable to update as it says “SC5000 PRIME IS NOT DETECTED” (see attached picture, please)

Unless I am doing something wrong?

I have downloaded the USB updater and added it to the usb stick, put the unit in update mode by pressing Eject + Source + Layer + power on" the screen is completely black as you said it could be.

Added the usb stick to the unit but nothing happens.

Anything else I could try, please?

Use a computer and usb cable to update.

Thank you for your help. I have tried that with my laptop and desktop, also on as friend’s MacBook, none are recognising the unit. (See pic below)

  • Make sure you are using the correct cable/port (usb a - usb b cable).

  • Make sure you have the unit in update mode before you connect it to the PC and only after connecting it start the updater app.

  • Don’t have anything else plugged into the unit.

1 Like

The only other option is to contact support then.

1 Like

I have, waiting for an update/solution. Thanks

I have tried all that, but it won’t connect to laptop, it doesn’t get recognised. Thanks :+1:t2:

Have you installed the driver under Windows?

Then again, MacOS also didn’t work and I think the SC’s are class compliant.

Yes, I tried it via Windows. Also via MacOs. Cheers!