SC Live 4 Noise Sweep Effect Not Working

Hi there,

I have an SC Live 4 which is updated to the latest software version.

The fault/problem that i have is with the “Noise” Sweep Effect. When i press it & turn the activation knob under the deck playing or any of the decks for that matter with volume sliders up to max on each channel, it doesnt work, no effect sound at all, the button flashes as it should when activated & triggered but nothing.

It has worked before in the past.

All other Sweep Effects work fine as they should with no problems at all.

Is this a known fault?

Something i am missing or not doing?


DJ Master G

1 Like

I’ve experienced this once.

I moved the internet speaker volume and master out volume to min/max and it seemed to start working.

Hi MrWilks,

Thank you for your reply, that is something that i will definately try as i didnt think to do that at all lol.

When I had this issue I noticed two things.

First I noticed that when I created a 4 beat auto loop with the loop encoder on the right deck, I pressed the “loop out” button to try and shorten it and create an effect. Instead of shortening the loop, it did nothing but the light on the button cake on.

The second thing was three out of the four sweep FX worked. The noise did nothing. I tried for a while and nothing worked. I then played around with a few other knobs and went to the internal speaker control, turned on and the volume up and went back o the noise sweep. I wanted to test if it was not working on the master but worked on the internal speakers. I could hear it on the internal speakers so thought I’d try the master again and this time it was working!

Really strange.

I will have a mess about with it.

I literally thought i had a defective SC Live 4 & to be honest dont use the noise sweep effect much, but thought i would ask on here.

Its definately a really strange one & something hopefully Denon will sort in a future firmware update.

1 Like

I had this last night on channel 1 sweep fx knob. I think I switched from 2 deck mode to 4 deck mode, and I also was changing the noise volume in the settings. Then the noise effect didn’t work on channel 1. Worked on all the other channels. The other effects, filter, echo, and wash still worked. Just noise on channel 1. Rebooted the unit and it came back.

1 Like


If it happens again, can you try pressing the “loop out” button and turn the platter to shorten the loop? That didn’t work for me when I had the noise sweep FX fail.

1 Like

Experiencing the same issue here, not sure how to resolve it :confused:

I played around with some faders, buttons and switches and it just started working after a while. Maybe a reboot works?

Noticed the same issue, i think since the 3.0 Firmware Update. Couldn’t make it work by turning any of the knobs or a reboot :frowning:

hello, had the same problem with the noise effect, for me it has to do with the position of the crossfader, fader in the middle all channels work

1 Like

I’ve just tested that and yes that seems to be a cause of missing noise. For me, all 4 channels the noise is faded out with the cross fader. I have all channels set to THRU mode. Essentially far left is noise at 0, and moving the right increases noise level.

Wonder if this is some kind of half-implemented feature.

I’m sure it’s probably related, but not exactly the same as what I had. Other channels the noise worked for me, just not on channel 1.

Looks like a bug to me. I can’t test as I’m without the SC Live 4 now but looks like it could be part off the issue.

Can confirm that the noise fx is not working whenever the crossfader is pushed to the leftmost position. Regardless of the channels being set to THRU. Thanks guys!

This is fixed in 3.1 it looks like to me. Crossfader to the left, noise still working on all channels.