SC Live 4 - Can't access USB storage via computer mode (but standalone, serato, audio OK)

I’ve recently received by SC Live 4 and have been testing out the performance features in standalone mode.What I’d like to do is be able to update the library on the device (the SD card slot) without having to take the card out and plug it into a computer. I believe this is something that should work, but isn’t working for me, for some odd reason. I have already updated the device to Engine OS 3.0.1.

Things I have tried:

  • I have tried two different Windows machines (AMD based Win 11, Intel based Win 10) plus an M2 based Macbook.
  • I have tried different USB A–>B cables, including the one that came with the unit.
  • I have tried different USB ports on the devices, including regular USB, USB C with an adapter
  • I have tried adding a USB 2.0 or USB 3.0 port inbetween
  • Factory resetting the device from the About page in Engine OS

None of this seems to have worked :confused:

But… the decks in standalone mode read the device, Engine DJ software seems to be working (but of course no devices shown), Engine OS reads the USB sticks + SD sticks.

Also controller mode with Serato is working and unlocked, screen shows stuff from it, audio output works.

Here is screenshot of the device tree from Device Manager in Windows 11. The extent of the device is shown, no USB mass storage-like devices there :frowning:

Screenshot 2023-04-14 220242

EDIT: not correct info, see later posts

Should not. SD card reader is not internally connected to the USB hub of the device and the same is on all prime hardware.

Seems the logic is that you can easily pop out the SD card and plug it into the computer.

OK, that’s good to know.

But all my USB drives don’t show up either?

So yeah for the USB drives, it does seem like it’s a feature that should be working for me. As when leaving standalone it tells me to make sure I eject the connected drives. Which of course isn’t possible considering they don’t show up in the computer’s OS.

Anyone else experienced this?

@NoiseRiser has SCLIVE. Tagged him.

Hello, I did some tests on the availability of the external storage media on the live4 on my macbook pro M1, and I could access my SD card via the usb cable in computer mode. I was running the V2.4 software when I did this test. Tomorrow I will check on V3.xx if that is still working or broken. Recently I was having my SC Live 4 in a place of my house where usb connection was not an option, so I was removing the drives from my unit. But as said, I will test it tomorrow for You.

Weird, I tried on 2.4.0 last night as well and I had no luck. Will be interested to see your results on 3.0.1 still.

You have to eject your connected drives when switching between computer mode and stand alone.

Yup, NoiseRiser proved me wrong. Interesting that it is different to Prime 4.

1 Like

Today I made the tests on latest software and I got surprised. No usb or SD card was available. Definitely I could swear that I had this on 2.4, but I see 3.0 is not giving us this option. I think this needs to be a bug report…

1 Like

I even rolled back to 2.3.3 and no go. Device came with 2.4.0 originally though.

Thanks for trying it out!


When on 2.3.3, unit reported: Engine OS 2.3.3 / Controller version

When on 3.0.1, unit reported: Engine OS 3.0.1 / Controller version


How do we submit bug reports?

Unless it’s just for the built in HDD? I’ve not had my P4 powered on in almost a year so the memories are hazy at best.

Since NoiseRiser confirmed he was able to access the SD card in computer mode on a older firmware at this point I think only 2 options exist:

  • firmware bug that was not noticed in new versions
  • intentional “allignment” of features in the Prime lineup

I have the same problem on 3.0.1 , trying to reinstall the drivers in Windows, but didn’t work. It works if you put in the SD slot to PC.