Right deck problems on prime 4

I have ran into a issue with my trusty prime 4 The right side deck has a issue when it will suddenly stop playing and become unresponsive to any playback you can change the cue point but it will not play ,you can make a scratch sound if you push the jog wheel but play is impossible .if I then change from deck 2 to 4 the other deck is playable like normal however after a few minutes this will also stop but then deck 2 will kick in and play straight away without being commanded to I am in the process of crafting a mix so I’m still being able to be productive and work around this problem for the meantime but it is no good for when I need it to be a normal mixer . Any suggestions?


Did You noticed a jog wheel color change in that moment? It looks like Your jog wheel is detecting a touch. Turn off vinyl mode and check.

1 Like

I had the same kind of problem with my old traktor s4 mk2. I cleaned my deck completly with a cloth and compressed air(be careful). Then i restarted and it helped.

To be sure it’s no software-problem, have you updated and reseted the prime 4? Came it after an update?

Also it could be a malfunction at the jog (maybe the touchsensor). This could be the worst case, i think.

I had my first issue with right deck (2) just stopping. Was on 1.5.1 & no issues until yesterday. I hadn’t used the P4 for about 10 days (the longest time w/o use since having it a year ago) but yesterday it stopped. The cues & play button worked but not playback. If it it randomly start, it would then stop again. On all tracks on deck 2.

Updated to 1.5.2 but the same issue. Reboot solved… until next time. Frustrated.

I had the same problem yesterday and day before swapping from channels 2 and 4 randomly . today no problems for two hours plus and finished my session without a issue . It is definitely a worrisome problem as I’m convinced it’s not anything I have done differently it would be a disaster if it happened in a live situation

1 Like

Exact same problem here - plenty of threads like this and it is a KNOWN ISSUE by Denon and the latest response is to “wait and try firmware 1.6” which should be out in a “few weeks” (that was as of two weeks ago). It is NOT platter sensitivity or vinyl mode. I don’t even touch the platter, just use the arrow keys in the middle of the mixer to load a track then hit play on the deck. No platter involvement at all.

It’s very strange but it hasn’t happened for about a week now no idea what went on but I would ■■■■ myself if I was using it for a live performance

Happened to me the very first time I used it live and it completely ruined the set and the vibe. Impossible to recover after that though I did my best. Have not played at a live event with it since.

This morning no end of problems. The platter is constantly flashing two colours which I know will cause problems. Tonight recorded my radio show no problem at all. Platter stayed the one colour. Now sent four videos as requested but still no response to the emails. Spent nearly an hour waiting for support to answer, gave up in the end. I have had enough. Are they trying to make us look stupid when we do events. I have passed over my bookings as I just can’t take the chance of it going wrong at a wedding or other event. I expected big things from Denon and have all ways used their equipment. No more.

try to do jog calibration

Thanks Carl, have already done that. They kept telling me that back in September before they eventually took it back and so called repaired it.

Well, it’s out - Engine 1.6 - let’s hope this one finally eliminates the deck issues so many of us are experiencing.

No difference, platter still flashing purple and white, 48 minutes into recording shoes press to start track and nothing. On a good note they have agreed to it being returned and look at the fault. Waiting to hear how you get on.

Same here though in my case it’s the left deck. The first time it stopped responding I was able to get it to play by messing with the jogwheel and hitting the cue and play buttons a bunch of times, but then was unable to duplicate that again. Prime 4 is going back :frowning:

I had this issue a while back, returned to dealer for warranty repair and entire right had side of the unit was replaced