Rekordbox beatgrids to engine

Hi. I try import my 20k rekordbox collection to engine but the grids and hot cues are off on every track. I made video what i did, if theres something wrong i was doing then pls help :slight_smile: My collection is like 90% gridded and hot cues marked would ■■■■ to do everything again. I tested with loop if it just looked wrong but nope the loop was off too because the grid.

as far as I know you are doing everything the right way.

There is another option:

Use rekordcloud / lexicon. This program is specially designed to convert collections to and from different programs like Engine, Rekordbox, Serato, Virtual DJ, etc.

FYI: lexicon is the new version of rekordcloud. rekordcloud is an online app and lexicon is an app on your computer.

It works very well and has a lot very nice exclusive features. Maybe when trying this it will work for you.

LINK: [Introducing Lexicon - rekordcloud]

please let us know if this is a workaround for you

1 Like

Okay thanks for the info. Yeah it is annoying like all the grids are off same ammount. Its not that bad to shift the grid but the hot cues is mega annoying as you would need to put them 1 by 1 to the grid again. I heard with SC6000 you can shift all hot cues together to grid why cant do same in engine?

But yeah i need to try that lexicon, really hope it will help!


Well i tryed lexicon now but didnt work. The grids were off in lexicon also same ammount as in engine and when syncing with engine nothing change. So i have to do manually everything again :frowning: 8 years of work :cold_sweat: If denon could put atleast that hot cue shift to engine that would make me happy.

You can shift the beatgrids and hotcues in lexicon

I tryed but sadly the cues didnt stay on grids. Like the couple first one was right but not rest. Also the grid sometimes was still not correct. Not sure is the problem because this is in beta but for now need to do it manually for perfect result :frowning_face: And why i need it to be perfect is i started using synth/akai force and i need them to sync to grids for my live performance.

EDIT: After all testing best thing seems to be let engine analyze grid its actually good, mostly on point and just put all cues again.

There must be an option to lock the beatgrid. Maybe that will solve it

Yes there was all lock function but it didn’t help much as i would needed shift every single beatgrid in lexicon and even then some cues were off. So i came in conclusion that its better start fresh engine and import tracks and let engine do the thing, that way i just need to add hot cues and just 1 click beatgrid shift sometimes. Not fun but i think i have to do it if want to move to denon. Not fully decided yet.

So i think if want everything to work perfect, import collection to another you need to have lossless format not mp3.

I think you are right about that.

I see you allready have auto analyse OFF. The BPM range is standard set to 88-175. In my collection Engine works better if I set it to 78-155. Maybe you can try that?

1 Like

You can shift all the Hotcues in Engine OS

Hold shift and push the Encoder knob (that’s the combo on the 5/6000)

It will enter a grid edit mode but only moving the hotcues

I wonder why the beat grid and hot cues are off at all? The rekordbox xml format is very clear and easy to understand. If it is a systematic error, it should be fixed.

If the offset is always the same - either absolute or as a fraction of the BPM - it would be easy to apply the required change to whole .xml file with a little script / tool.

1 Like

Probably the infamous beatshift problem. Lexicon has a scan for it that catches most of the tracks affected by it.

@DJFITME There are several ways to shift cues/grid in Lexicon. There is a recipe where you can shift as many tracks as you want in one go, just enter the millisecond amount you want there. The more hands-on way is to set up a hotkey for “Move current marker left/right”. This lets you move the entire grid very easily and precise. With Quantize enabled, your cues move with them. And if you ever find cues that are not exactly on the right, then run the Quantize Cues recipe and your cues will be put nicely on the beatgrid again.

Hope that helps!


This helped me to fix all at once. I found that all grids and cues were 15ms off. I just put that to gridshift recipe and now all fixed. Thanks!

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.