Reinstall firmware possible?

I’m having an issue with my MCX8000. I both made a thread here, as well as submitted a ticket to Denon, but haven’t received a response. I’m assuming Denon is closed due to the quarantine. My question:

Is it possible to reinstall the firmware? I tried, but my unit just said the firmware is up-to-date and didn’t give me any other options.

It’s the last thing I can think of to do before I completely give up. Thanks in advance for any input.

This might work. Not sure what the issue is with customer service but a few people mentioning they’re getting no response.

Place a USB drive that contains the latest firmware update package into USB 1.

Power on the MCX8000.

The left deck Cue button will flash. Press the Cue button.

The left deck Sync button will flash. This indicates the unit is updating.

When the left deck Play button is lit solid green the update is complete.

Turn the MCX8000 off, count to 4, then turn it back on again.

Thanks for the response. I forgot to mention that I tried that method earlier, but the left deck’s cue button doesn’t flash when I power the MCX8000 on. When I go into the settings menu to update the firmware as normal though, it does recognize that the firmware is on the thumb drive.

Do you happen to know if the left deck cue button not flashing is due to something I’m doing on my end? I know you’re not Denon tech support, but I figured I’d ask anyway.

Not sure. Sometimes this works but not on all units.

What issue are you having exactly that a reflash will fix?

The issue seems to be confined to the right deck: At random intervals, the MCX will set/engage cue 4, and also randomly start/stop playback. This happens in both Engine/standalone mode and while controlling Serato.

I’ve done all the basic troubleshooting that I could think of - powering off/on, swapping USB cables, using a different thumb drive, etc. None of those seemed to fix the problem, so I figured I’d try to reinstall the firmware as a last ditch effort while I’m waiting for Denon support to get back to me.

Sounds more like a hardware fault.

Reflashing won’t fix things like that. Effectively all it does is exactly the same as the factory reset option in the settings menu.

Yeah, that’s what I was afraid of. Thanks again for your replies.