Recording X1850 > Audacity, Windows

I record to Audacity on a Windows laptop via usb. The recording is fine until it’s not. The sound has some artifacts that last for 5, 10 maybe 15 seconds. It sounds like a bitcrush effect. I think it may be the computer not being able to process the audio. Does this sound possible? Should I buy an audio interface?

You shouldn’t need an audio interface, and you should get better & easier results just with the mixer, a usb cable, and your computer.

Check your levels throughout the chain just to ensure you’re not clipping anything. Mixer has settings in the utility, Windows has settings, and Audacity does, too.

Ensure the mixer’s firmware is up to date.

Uninstall and reinstall your Denon DJ X1850 drivers.

Check power plan & standby settings on your laptop. Put them on High Performance and make sure the laptop is plugged in. You don’t want anything going to sleep.

You might want to also go into device manager to ensure the USB ports don’t have the ability to sleep from some setting in there, either.

Try a different USB cable.

Try a different computer USB port.

Check that the sample rate settings are all in agreement for:

  • Audacity,
  • The actual mixer,
  • Windows Sound for the mixer channels,
  • Denon DJ Prime Control utility.

If all that’s all fine, try increasing the Preferred Buffer Size in the Denon DJ Prime Control utility.

If you’re still experiencing issues, disable all channels to and from the mixer you aren’t using in Windows Sound and set the ones you are using to 16bit.

I would also download and use DPC Latency Checker, then start troubleshooting if there’s programs or processes that might be interfering.

Perhaps others can chime in about when it’s time to look into more mixer hardware issues.

Thanks for the detailed reply. It’s not clipping, I get that sometimes because I push it too loud. The sound is very sporadic.

And thanks again, gives me a few more things to look for

I would suggest increasing ASIO buffer size first (assuming you are actually using the ASIO driver).

You didn’t say what it’s currently set to, and Reticuli didn’t ask. The idea is to set it so that you don’t get glitches in the audio. There’ll be a default setting but it isn’t always suitable (depending on your particular setup).

I’m using the supplied Windows Audio driver, the buffer was set to 256, shall I push it all the way to 2048?

What latency (the milliseconds figure) was 256 giving you?

Just increase it gradually until the problem goes away.

Ummm, I increase the buffer but it has no bearing on me at the time as I am listening to the sound from the mixer, not the computer. Is there any reason then not to use the maximum?


That’s the default and should be sufficient for USB 2.0 on a short, good quality cable with 10 stereo channels of 24/96, but once you start throwing in long cables, and all the other issues I mentioned, it can end up being problematic. That’s the best way to test it, though, maxing it out like that. If it makes no difference, put it back down to 256 or 512 samples buffered, as otherwise you’re using up RAM needlessly and increase likelihood of other issues.

I assume you’re already running at 48khz, right? The X1850 apparently has a noise defect in 96khz, anyway.

Another thing you might want to try is simply using OBS. I stream and record at the same time into OBS most sessions. Maybe you have a problem with your install of Audacity. Eventually you might want to try other software to see if glitches persist.


There’s the rub. Obviously if the goal is to check whether the glitches go away, you’ll need to listen from the computer end of the chain (and have the hardware connected).

96kHz was the issue, cheers

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.