Problems Setting Up SC2900 And A Network (Solved)

JackHadaGroove Mar 11, 2015 1:34 am

Hi Guys,

So I got my first SC2900 a few days ago. I was reading in the manual that you can plug the player directly into the laptop/PC, no need for a router. I followed the instructions in the guide and setup a static IP address and just can’t get it to link up. I’m lost. Can someone please maybe outline the steps I have to take in order to get this up and running. I’m running Win 7 64bit. It shows in the network and sharing centre as “unidentified network” and the connection is crossed is being sent but not recieved. I set the Network ID to “1” Thank you :slight_smile:

Dj-msx Mar 11, 2015 7:51 am

Are you using a crossover type cable (it will be labelled ‘xover’)? What IP address did you set?

JackHadaGroove Mar 11, 2015 11:22 am

Thanks for the reply. I’m using Cat 5e LAN cable. Doesn’t say xover on it. The IP address I have set is as per the guide, Subnet Mask is, So perhaps it’s because I’m not using RJ45 xover cable then?

Dj-msx Mar 11, 2015 10:56 pm Re: Problems Setting Up SC2900 And A Network It depends on your computer. Some computers will automatically sense that the transmit and receive twisted pairs of wire need to be swapped (crossed over) and do it electronically. Other computers won’t, as they usually don’t need to since most hubs and switches will do the job so they wouldn’t normally need to.

In short, it should tell you if it can auto-sense it in the laptop manual or manufacturers website. This will tell you if you need the crossover cable or not.

JackHadaGroove Mar 12, 2015 5:19 pm

Had a look at the manufacturers site, Realtek, about the adaptor I have. It’s very vague. Mentions crossover etc. I had a look at the advanced properties of the adaptor to see if crossover was disabled and there isn’t even an option for it. The laptop I have is a Samsung RV711 i3 so it’s not that old. I have noticed that the network type is public and not home. It just will not let me change it. I’ve even gone into gpedit to allow me overide what windows sees fit to set it to, but it just defaults back to public, then tells me I can’t change it. I’ve setup the homegroup to share everything regardless of it being public or home. I guess I will have to get some crossover cable and see if that works. Did you just network everything on your SC2900s and it worked first time?

Dj-msx Mar 12, 2015 7:45 pm

Obviously it’s not going to show any normal network function in this arrangement in windows, but if engine is definitely allowed through the firewall and the cable is ok then when the deck boots up it should hopefully find engine running on the pc, even if you need to hit the link button to make it happen.

JackHadaGroove Mar 12, 2015 10:03 pm

The firewall was the issue. It did not ask me, even when I re-installed Engine if it was to be allowed through. I had to manually set it to allow Engine through both on public and home connections.

My next issue is that I seem to have lost the wave display with the time, bpm etc in Engine. All I get is the library as soon as I plug in the ethernet cable to the unit and the laptop. Is that normal?

Dj-msx Mar 13, 2015 7:22 pm

If the engine library has been scanned fully for memo data, and the decks firmware is up to date ( current version 1168, see link - viewtopic.php?f=63&t=21410 ), then it would normally load track with all the memo data you have saved in engine, and waveform loaded ready to go. If it is already up to date, then don’t try and redo it.

Worst case, you can rebuild the database by deleting the Denon2 folder from the hard drives root directory and scanning it again.

JackHadaGroove Mar 14, 2015 9:07 am

Thanks for your help mate. I will try this after work. :slight_smile:

robdquick Mar 16, 2015 9:45 am

This is normal, and is the way that engine works. All that is displayed in Engine on the laptop when a unit is connected is the library, all other information is displayed on the deck.