Prime 4 & Virtual Dj tracks not playing

I have just connected my new Prime 4 controller to my laptop with VDJ. I jave been with VDJ for over 13 years!

Everything has gone ok and i can control VDJ from my Prime 4 but, when i press Play, the track gets stuck in the same spot and the waveform ‘vibrates’ like it is on a look.

I have installed everything i can find on both VDJ and Denon sites. I have checked all my setting. I thought it may be the Asio driver but ive reinstalled it 3 times and still nothing!

Quite disappointing when a £200 controller works immediately but an almost 2 grand controller takes a lot tweaking.

Follow up. I still have no luck! I have updated the Prime and even checked updates for my VDJ.

VDJ works fine on its own or when connected to my Numark mixtrack quad or my Pioneer. I have spent 4 hours and all the i structions dont make any sense. Checked the wedsite and it mentions some usb drivers “Download the dedicated driver from the “Download” section of the DA-10 page of the Denon website onto your PC.”. No link to the site. Searches bring up a product called DA-10.

First experience with Denon is turning out to be my last! I simply cannot trust these units for a gig!


one for you

1 Like

I don’t know where you get this info. That seems to be a product by Denon (not DenonDJ).

It is primarily a 2K stand-alone device that could act as a controller, yes.

So you do see the VirtualDJ interface, but it locks up or? Care to make a video of this and share it here, if possible?

Did you follow VirtualDJ - Hardware Manuals - Denon DJ - PRIME 4 - Setup and did you install for Windows? Tried another USB port or another computer entirely, if that’s an option?

Like Mufasa stated already @PKtheDJ is a VirtualDJ expert, so I hope he could chime in.

@kradcliffe I think you may be right as it started working after i uninstalled and reinstalled everything. I also changed the USB port i was using and restarted the laptop. Not sure which bit made it work but you may be on the money.

So the 7th time reinstall worked. :wink: Then it was most likely the change to another USB port. Glad it is solved.


What he said :grin:

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.