Prime 4 day 1 issue


Been at this for hours now. Prime 4 came today but still not been able to play any tracks! When i press play the waveforms doesn’t start, when i move the jog wheel nothing happens on the screen. I can load track, navigate menues etc but thats it. Ive downgraded/upgraded firmwares but always keep getting this update msg over and over…

how did you update ? I recommend you do it via mac or pc ! if you can’t keep the power button pressed until the unit restarts! try this but not via usb key !

what firmware version are you trying to install ?

Tried both ways multiple times now. Gone up and down several firmware versions both usb and pc method. Still not fixed it. Has to be a hardware fault so will be returning for a replacement next week…

have you tried restarting by holding the power button until it restarts?

when you update with your pc you have to remove the usb stick from the console! it must be connected only to the pc! you know ?

@djveleno: I’ve merged your post. Please use edit to change or add to a post. You can do this within 24 hours, I believe.

This way the discussion will read better for others.

Already done this at the start. Tried usb update with various versions. Usb removed when powered down. Tried multiple times connected to pc using all the firmware available on the site. Still not functioning. Im guessing its a hardware issue if its not booting the mixer side it.

you have to use the option you see in the second photo, not the first one

Yes this is how ive been doing it. This puts it in to firmware update mode so you can then run the updater on the pc.

then I’m sorry but I can’t help you anymore

Ok thanks for your input

Hi @CJG-DEN0N, welcome to the forum! Sorry to see you’re still having problems.

Like DJVeleno states, we’re limited in helping out when hardware issues occur. Are you able to return and exchange the unit at your reseller?

Best option, however, is to contact DenonDJ Global Support and let them sort things out for you.

Thanks, i have done this. Was interested to see if anyone else has encountered this issue. Ill get a replacement.

Yes a few have, but all ended up contacting support.

Keep us posted. I’ll leave this topic open for a few days.

Im now facing this issue. No lights on the unit but the screen is on and constantly looping the mixer update??

If you can get in Utility then try to update. Either via computer or usb-stick method.

Yeah tht sorted it thanks. Only back too not playing and tunes…

So you’re back into “device not loaded” again?

Yes. I have video of it but cant work out how to upload it?

Share it somewhere and link here, but the message is common and clear.

Mostly we cannot help with this through the forum. Sometimes a re-flash of firmware helps.

This topic was automatically closed after 2 days. New replies are no longer allowed.