Prime 2 sound issues?

Is anybody else having sound issues using prime 2?? The sound coming through my prime seems to be odd lateley I’m hearing quite high sounds and less bass :man_shrugging: also sometimes sounds a bit echoey I’ve done a full reset and update all my tracks are top quality I’m just wondering if the internal soundcard can become faulty?? I’ve no idea what’s going on but it doesn’t seem to be very well at the moment no matter what I try

What software version are you on? If it’s 2.4, I would reinstall 2.4 software…hard wire from your computer to the prime 2.

Headphones? Had that issue with worn out earpads, turns out leather pads give a more pronounced bass to the sound.

Ill dig mine out of the cupboard later this week and give it a blast at home, a couple of times at my gig on sat i thought i had the echo activated but didnt. This could be down to some delay between my monitor and the house speaker above my head though, its obviously loud in a bar so i didnt read too much into it. ill let you know when ive tested it.

1 Like

Yeah 2.4 I did it over WiFi will try that cheers

Speakers it is I’m using rokit 7s

Mine is still on 2.3.2 i think, I’m not sure about this 2.4, reading loads of issues on here.

You could try rolling back to see if it helps?

Yeah gonna give it a try also booked myself an hearing test :slight_smile:

1 Like

Never a bad thing to do. Too many DJs don’t look after their ears.

I have a medical every two years (just sat in the doctors waiting room now for this current one) and they test your ears every 10 years. It was last done two years ago and it was not pretty.

I do wear moulded plugs with -15db attenuation but often they come out to talk to someone and don’t get put back. I’ve only myself to blame!

Thank god they aren’t testing my hearing today.

1 Like

When I used to install my updates via Wi-Fi it always seem to not install all the files as needed to run my unit. I did my research to find a video on digital dj tips that stated updates on the prime 2/4 would have better results if hard wire from the pc or laptop. Download the files from engine dj website, run downloaded file, power on the unit and navigate to the update section, then use the blue cable that come with the unit. connect to the back of you unit and pc/laptop and click start. I hope this will help in some way.

I posted on the recent Instagram post about looking after ears… for years ive DJed with my headphones basically set so that im mixing on the percussion only. Every single DJ Ive ever played with has them at least 1/4 of a turn higher than I do and I have to turn it down when I jump on. Mine are still pretty good despite working in a loud warehouse, listening in headphones at home and DJing and I put it down to this low volume technique.

I wish I had a quid for every time ive put phones on after someone on the decks and thought wow thats way too loud.

You’ve probably already tried but the first thing I would check is the audio cables, could be as simple as a loose connection at the terminal or extension cable/adapter depending on your setup (that will give the exact symptom you are describing) It’s caught me out before. Also try swapping them out for others and trying the current ones on other equipment if you have the means, just to rule them out.

Same. I don’t know how some people can have them that loud.

So just got back from my MCA medical and they did the hearing test in the isolation booth. I’ve lots of high frequencies since two years ago. He said by the time I’m 70 I’ll probably need hearing aids. As I’ve changed doctor they said that I had to do the test again.

Anyway… sorry to derail this thread. I’ll shush now.

1 Like

Given some of the derails I think this one is allowed a pass. Important info especially for those who still have time to keep themselves right.

But yeah carry on with the sound issues for Prime 2.

1 Like

Little update rolled back a few updates still sounds shite, tried different speakers, leads running through soundcards etc and still the same I’ve got it booked in for a service now as I’m pretty sure it’s an issue within the controller. Will update when I know more cheers for the input everyone :facepunch: