Prime 2 mic not working

Has any one had a problem with the microphone not working. I was at a wedding and set up for the ceremony, everything worked great for the ceremony. I then had to break down and move to another location, that is when the mic would not work. I tried both mic 1 and mic 2 neither would work. I first thought the mic was bad so I tried my backup mic still didn’t work. The rest of the prime 2 functions worked fine. I removed the prime 2 and hooked up a Mackie mixer pro Fx8 and the mics worked fine. So it was a problem with the prime 2.

Hey @Partymixdj Sorry to hear you had some issues. If you’d like to further investigate this with technical support, feel free to DM me and I’ll be happy to connect you. There are a lot of factors to consider with an experience like this but overall walking through your setup is a good start.

Have you tried setting the system back up after shutting down and checking if the mic works?

Hi Anthony I tried that a few times. I am home now with the sister up and running. Today there was a new update, I have done that too. Are you available to DM and do a walk through

Was it master out which you had the speakers plugged into ? Rather than any other output ?

Good call.

If it was the “booth” output, it defaults to not play the mic though these speakers. Could we worth checking.

1 Like

Hello. I have the same problem with microphone slot. I tried few different microphones and still same problem. Maybe slot faulty …

Hello @Marek_Warchol Welcome to the forum.

Did You tried another mic and a new mic cable to rule out any other faults?

Yes. I tried 3 microphones and Normal xlr to big jack and than 3 different xlr cables. Looks like mic slot not working

What software are You on? Was the mic working when You bought the device?

Are you seeing the mic LED flashing? Are you seeing the mic signal on the main VU meters?

As above, make sure that you’re not using the booth output.

Microphone was fine. I use software 2.22 . My son was playing with the microphone and snapped the cables inside microphone. When I connected later I just had bzzzzz sound.

Well, there could be an issue then. The circuitry responsible for microphone input could get damaged that way…

I will send my unit to Denon service for diagnostic and will see what will be an issue. I will let you know

1 Like

Ok, good luck.