Prime 2 Freeze

Hello, I have a problem with the prime 2 unit. It just freezes on one channel and play button does not work. This problem appeard after the 2.2.0 update.

It happend in the midlle of a gig for the first time.

If i restart the unit it works fine for a while.

But having this issue i cant use this unit on a profesional level.

1 Like

More info. Tracks … source… which deck… what have you tried (update change/ rollback recently changed power cable). Do tracks run in engine ok??

Hey @Cristian_Chirica - Sorry to hear you’ve ran into some issues. We definitely would like to know more about your experience. Were you streaming music, playing from a drive, has this happened before,etc? Either way, it would be best to reach out to our technical support team and create a ticket so that they can run through some trouble shooting steps with you. Feel free to create a ticket via Denon DJ Support and we’ll be happy to help.

1 Like

The problem occurs with diferent tracks that run ok in engine and also on the unit (in another ocassion).

The source is internal ssd.

I have tried formating the ssd.

I will also try the following: -update to 2.2.1. -use another source (usb, sd card)

If any other idea please let me know

1 Like

Check cable is earthed and supply has good earth

This reminds me of the PrimeGO deck freeze issue when it was first launched.

Checked the cable. Everything is ok. I updated to 2.2.1. (As recomended by denon support) I will keep testing and come back with the results

I have the same issue as Cristian but it only happens on channel 1. I tried a three different power cables and made sure they were grounded and it still happened on the 2.2 update. I went back to 2.0 and I have not encountered the problem again so far.

Thanks for sharing @Skripez - I’ll share this feedback with the team.

After 24h from updating to 2.2.1 and lots of testing the problem didnt occour anymore.

I still dont trust the unit yet. I will test some more but it looks ok until now.

1 Like


I have had this issue happen to me twice at recent gigs, once on Firmware 2.2.0 and once on the latest firmware last night.

The only way to resolve it is to reboot the device which obviously at a venue isn’t the best situation, it takes a few minutes to boot back up.

From what I can work out it happens when you return the track back to its cue point and have it sat there not playing, the Cue and Play buttons disable but you are still able to scratch the platter, I can’t say for sure but I believe the hot cues don’t work either, they certainly don’t resume playback as I tried that.

Obviously there is no eject button to remove the track from the deck.

I spent the rest of the evening ensuring the track I’m cueing in was constantly playing in the background to try and avoid it happening again, only stopping it to actually cue in when I wanted to mix.

@Anthony_DDJ is this all the info you require?

I have reverted my firmware back to 2.1.0 for now as that was stable for me.

1 Like

This just happened to me on channel 2 on my prime 2. I had to reboot 3 times before it fixed itself. I looked pretty silly!
I’ve had it for 2 months and this is the first crash.


This is where I originally reported it.

Just picked up my Prime 2. I also have 1 channel not play consistantly. Using same track, it plays on one not the other. I can scratch track. I can fast forward thru track on screen touch. I can occasionally get the track started by switching deck 2 thru switch on unit front from “thru” to another position. deck one stays on “thru” yet always starts.

I have updated to ver 2.4 and am using a 1 TB ssd drive in “usb 1”

Hi glad I found this I too am having the same issue nothing to do with updates as I have updated every time but it happens occasionally. Not at every gig. I have resorted to keeping my laptop and mixer beside me in case i need to switch over but this means taking an xlr out of my prime into the mixer playing with one speaker until such time as i re boot prime. There doesn’t seem to be an rhyme or reason I use a 1tb internal sata drive and also have an external drive for newer updated songs. At a gig yesterday I re started 3 times then it was fine unfortunately i didn’t have a back up. At first the righthand side became jumpy and then froze altogether the Left side never seems to have an issue

Mine was an earthing issue with the capacitive touch platter on the left deck, it required a repair to put right. Essentially the controller thought my hand was on the platter when it wasn’t.