Playlists and tracks not syncing to Prime 4

I’m having a number of issues synching my tracks from Engine DJ to my Prime 4. I started by moving over all my playlists from Serato and that worked fine but now my process for creating new playlists in Engine DJ and getting them on the Prime 4 is not working, and i cant find a consistent issue even. Sometimes the new playlist title moves over but the tracks aren’t there. So I started just making new playlists right on the Prime 4 but then the last time I tried to transfer some new tracks over from engine DJ it erased those playlists on the standalone. I love my Prime 4 butnim VERY frustrated with these problems. Can anyone help me out? I’m on an older Macbook Air, and have a new internal SSD in the Prime 4.


firstly ill address your issue with on device changes being deleted. If you make any changes on device you need to ‘sync to Engine desktop’ in the sync manager before you load any new music to the device, this should then update Engine desktop with any changes you make.

What is your workflow for adding new tracks and playlists to Engine desktop? I notice you said the initial load was through Serato, i did that too. Im now convinced that i need to start independently adding new music to Engine desktop and remove Serato from the workflow altogether as it causes too many issues trying to use Serato as the master data file.

Thanks STU, I’ve been scared to ‘sync to Engine desktop’ thinking it might erase files on Engine DJ. I’ll try it.

My workflow is to create a new playlist in Collection, drop tracks in there from my downloads folder, and then sync. But the original playlists made through Serato seem to be the only ones to sync properly.

Now it’s even more weird. I’ve made a new test playlist on the Prime 4, and it sees it in the sync manager, but doesn’t give me the option to ‘sync to Engine desktop’ anymore - it’s greyed out.

And new playlists I’m making on Engine desktop aren’t transferring over in the sync anymore - the sync on the right (and the Prime 4) have a ‘ghost’ playlist that I made a while ago, but there are no tracks in it and it’s not on the desktop anymore. The two databases are basically not communicating anymore, there must be some systemic issue?

Beyond frustrating, basically unable to get new music on the machine.

Do you have to scroll down the list in sync manager and tick the new playlists before you sync?

When I create new ones on mine it won’t add them until I’ve ticked them off. Another way would be to untick all using the master box at the top, then re-apply it.

This definitely works for adding playlists to the device, I’m not sure about the other way around (sync to engine desktop) but worth a look.

I don’t actually get the option to tick any boxes on those playlists, they don’t appear just as the option to sync back below doesn’t appear. It’s almost as if it’s not seeing any new data to sync, even though the new playlist title is there. It actually says below ‘no new information to sync’.

Hmmm, you dont have a DB compatibility issue do you? when I upgraded my OS and Desktop app to the 3.0 versions I did a clean install of my SSD as the DB was a new version. Might be worth formatting your SSD and reloading it to see if that solves it.