Playlist not copying to USB-Database problem?

Hi there, Recently added playlists are not copying over to USB. Here’s what’s happened. I’ve been building a playlist the last couple of weeks. It was copying fine over to the USB. Last week I upgraded to Vers. 2.2.2. It was still copying over OK until a couple of days ago. Now it won’t copy over. Old playlist ( like very old) will still copy over but not recent ones including ones from the past couple of months. I uninstalled and reinstalled ver.2.2.2. I uninstalled and rolled back to ver 2.2.1. to no effect.
Using the Sync Manager I can copy the files themselves and they retain the cues and loops info. But no playlist so they are not in the order I want. Reading through this forum there seems to be a historic problem with the Engine software databases so I suspect it may be something to with that but I really don’t understand databases that well so don’t know how to approach this. I work as an editor in TV and in the software that I use when databases get corrupted you can trash a couple of files and they’ll re-build and you won’t lose any of the equivalent data like cues and loops and playlist order. Is there the same kind of thing with the Engine databases? Is it a database problem anyway? Or is something I’m doing? (I’m always ready to blame myself). Any help is greatly appreciated because it’s driving me up the wall. Cheers D


If it does not want to import the latest music, to correct this you simply have to delete or move the “Engine Library Backup” folder, a backup should be made and strangely… this blocks the possibility of adding files!

An update will be available very soon to correct this!

If you have created cue points, loops… To refresh this, you must make a selection of all your files then right click on the pad or the mouse and choose “Re-Import Tracks Information”

1 Like

Thanks very much for your reply DjMe3ll26, I’ll do that if I have any more trouble. I think I’ve solved it another way. I read the manual this morning and only just clocked that it says in there that playlists have a limit of 1000 tracks. A couple of versions ago when Denon got rid of the crate system it started to take a very long time for itunes to update within Engine and I got pretty frustrated so I just started using a playlist to transfer all my music to Engine and that became my central ‘crate’. I would just drag and drop into a playlist and ended up with a playlist of around 4500 tracks. I’ve deleted that playlist, re-installed Engine and transferred the tracks back in to multiple playlists and that seems to have solved the initial problem which was the inability to copy playlists to a USB. I can now add tracks again too.

I’m having a similar issue. I cant transfer any tracks onto my usb drive. It just comes up with a small red circle, similar to a no entry sign.

Mr Janus, Have you tried the 2 approaches outlined above?

Ive moved the backup folder and I can now move tracks. It’s still not working with itunes though, which is what I normally use. i love my Denon setup but Engine is not good.