Numark Mixstream not working after update

Hey all, so i just updated my Numark Mixstream from Firmware 2.4 to 3.0 and also the app on my mac and now the buttons are not working anymore, just the jogwheel and the sync button is now mapped as the lighting button, looks like the button mapping is totally wrong. I dont know what to do, i already did restore it and also went back to firmware 2.4 but its still the same.

Anyone had to deal with the same problem ?

Thanks a lot

Upgrade from the device itself. The update is not complete. Retry it

There could have been a mixer/controller update for the Mixstream. As said, give it another go as this should hopefully reload the mixer firmware (it comes as part of the main update but is separate to the Engine OS update).

I’ve had a few hardware updates that arrive with the software OS update and they usually go well but I didn’t have one that failed to load fully.

Hey Thanks a lot, but still nothing, i updated also connecting directly to the computer. i put it back to the first engine firmware and got step by step again to the newest and still the same problem.

Hey where i can find the extra update ? cant find it on the numark page i have Controller version

It comes with the Engine EOS. If you update again it may trigger it unless that is the latest version.

It maybe just the wrong version.

It sounds strange but retry the download and make sure it’s the exact one you have. Just in case the firmware is different for the plus version.

EDIT: Definitely check you’ve not got the Mixstream + firmware accidentally as there is two versions of that controller. It may not even load if it’s the wrong firmware but it sounds like having an Engine Lighting physical button could mean it is the wrong firmware. I maybe wrong though.

I have the original mix stream pro and upgraded the firmware via wifi … a few things were not working as before so i did factory reset and it worked . No problems since

OK i did it, but its not changing anything. thanks for the tip anyway

I had the same issue, my “web” WiFi update got stuck at 0 kbps while downloading. Turned off the controller (it was stuck for over an hour) and half of the buttons were mapped to random stuff.

Here’s what worked for me: I did a couple factory resets, downgraded my engine OS a couple times from 3.0.1 to 3.0.0 to 2.4.0, then back to 3.0.1 using the “update from web” connected to WiFi. Voila, Fixed.

Well, it just happened again. I accidentally unplugged the Mixstream without shutting down and it’s back to the wrong button mappings.

I have a feeling it might be the controller version, but as I understand there’s no way to change that.

Can someone from Denon please help?? This is clearly an engine OS issue.