No Sound? (just got it today)

My P4 arrived today had V 1.3.2 in it. Loaded 10 songs by USB, press play, no sound, no LED meters. Spent the next hour updated to firmware V 1.4. 0 press play, no sound. tried 4 other songs, same result. (all mp3)

  • have fader in the middle
  • have volume up 70%
  • headphone volume 50%
  • MIX is in the middle of Cue/Master
  • Shows waveform while playing

I know that there must be 1 thing that I am not doing. I don’t want to send it back. :frowning:

1 Like

When I first got mine I encountered the same but it just took getting used to where everything is. I recommend checking the master knob/dial that is to the right of the screen. Turn it to the right and see if you get audio coming through. Make sure your channel faders are up as well so audio can come through. Obviously check your speakers and connections that you have as well. If you are not getting audio through your headphones, turn the headphone dial toward the CUE position then press the CUE button under the desired track channel you want to listen to (watch your volume so you don’t blow your ear drums out though!) :stuck_out_tongue:

1 Like

I turned the master knob half way (it’s late I have on headphones, no speakers connected) still No Sound. :sob:

I edited my post to include some additional information for headphones. Make sure you have the CUE button pressed under the channel you want to listen to (it will light up nice and bright once enabled). At that point, turn the dial above the headphone volume all the way to the left so its fully on CUE and see if you can hear the track. Try checking with different headphones you have just in case too. Let me know if that helps.

1 Like

Didn’t work. Is there supposed to be a led signal on the fader channel? It’s not coming lighting up at all

It should. As long as the track is playing. Make sure the SWEEP FX knob is in neutral, make sure no FX are enabled and that your channels switch (very bottom of the channel faders) is set to THRU and not L or R (this is for testing purposes only). Also double check that the gain knob (grey knob above HIGH) is turned to a decent level. To confirm, you are loading from a USB flash drive or where are you playing media from?


It was the SWEEP FX! I had it all the way to the left. (Thought that I was to only have it on when using effects) THANK YOU VERY MUCH! You made my morning, lol.


Woo hoo!!! Glad to hear it man! I’m happy I was able to help. :smile: Again, I was in a similar boat and had to troubleshoot on my own with those methods so I was able to relate and knew it had to be something like that haha! Have a great weekend! <3


You too happy mixes


I’ve done that too lol. All in a days adventures man.