No network connection was detected

And the first Prime 4 issue after 2 years just come: Connected to wifi ok, I can see the unit in my rooter device list but when I try to connect to any service like Beatport, Beatsource, etc the message coming up: No Connection. No network connection was detected. This error come up on version 2.3.1 on wifi or wire network also, on any kind of rooter or wifi security or non security network, so is clear a device problem. I also update the firmware to last version 2.3.2 and nothing, until today was working great on 2.3.1, from today doesn’t wand anything about network.

Top right also seems to show a connection to the router, so this looks like a connection problem

An other option to try is with an Android phone. Turn off Wi-Fi and go online with 4G/5G, then set up a hotspot from your phone. This way you will bypass your router and network.

If you can connect then the problem is to be found in the network/router. If you still can’t connect on a mobile connection with an Android hotspot and flashing firmware does not help either support from Denon is needed

As I said in my post, already tried other connections including the networking cable, is not a connection issue, is the console software problem, even the update is not working via internet, i made it via usb. I tried, wifi from phones, 3 different rooters, networking cable, nothing works all same error, no internet connection. But in the same time i can see the console and ping from any other device, so no network issue.

Could it be location?

Are those online services available via a normal pc/phone in your country?

Network RJ45 port is a link cable, not for network connection, so that wouldn’t prove much. I have found that I’ve had to forget my WiFi and reconnect (more than once) guessing you already tried that?

All prime series devices can be connected to local area network via rj45 connector. They will work with outside world just like with wifi.

I was using Beatport and Beatsource 2 years…

Yes, full network functionality as Wifi, was using at home before this problem comes out.

No, the network plug have full network functions including ableton link, firmware update or services music.

I downgrade until 1.6 and still same error, I think the last update (2.3.2) affect the network hardware and now cannot be fixed anymore via software, lets see the next update :rage:

I have the same problem as well, I can’t connect to any Wifi after updating to 2.3.2. We must have a fix to this issue…I use alot of stream services for my gigs! the error i get is (Wifi login failed Input/ouput error)

I was on older firmware and couldn’t get units to connect to wifi network so I updated to 2.3.2 to see if that would help and all I am getting is same problem/similar error messages as your getting. Trying to set up mobile tethering/wifi hotspot on iPhone yields same results :man_shrugging:

They should repair this units for free somehow if via software updates are not working anymore, because is clear denon issue, see that i’m not alone in this matter.

1 Like

I have a mobile broadband wireless device(portable)with an Ethernet port and I was able to activate the use Ethernet port in my devices settings then I connected it with cable to LAN port on my SC5000M and straight away was able to access Tidal/Beatport log in screen however can only use the one player/2 layers with this method. Still wish I could just use wireless connection from my device. I’m using an Inseego mifi device 2.4GHz/5GHz Previously I was using a Huawei B818-263 wireless device and didn’t have any issues however that was when I was running older OS firmware.

Any chance to test it with an Android hotspot? Sadly Apple has his own issues with hotspots on iOs (Engine DJ | Unable to Connect to Personal Hot Spot from iPhone or iPad | Engine DJ)

I have the same issue as well since updating to 2.3.2 along with not able to connect to any wifi network. Engine DJ will someone to please response to address these issues seriously. This should be an emergency hot fix to resolve these core issues. I’m a software developer and i don’t understand on how this release was pushed without being properly unit tested and regression tested before releasing to the public! I’m extremely upset with the lack of response from your support. I have the Prime 4 and a go and i’m a mobile dj who needs to access the Wifi for streaming customers requests.