Mcx8000 - Play/Pause/Stutte button - strange behavior

Hello! I discovered your forum today and I am happily surprised!

I’ll start by saying that not too long ago I became the owner of DENON mcx 8000. I’m a complete beginner, with a lot of enthusiasm.

For a few days something has been happening to me with the button - Play/Pause (with both left and right buttons), and I don’t know if it’s normal, is it from the software (Serato DJ) and how to fix it? Sometimes when I press the button to pause the track, the sound stops but, the track keeps moving. When I press it again it stops. Forgive me if my question is trivial or if it doesn’t belong here, but I’m a beginner, and I want to know that everything is fine with my controller.

In addition: I noticed that the movement on the track remains only in the controller screens. It stops right in Serato. When pressed again to stop/start it, it starts playing exactly from the position it stopped at, regardless of having visually moved before.

Also, when I loaded a new song, it started muting the headphones and I had to press cue buttons again. I did a factory reset and that fixed the problem for now. Now all that’s left is the strange behavior of the play/pause button. I really hope everything is fine with the controller and these issues are coming from my computer or serato. I really liked this controller and I don’t want to return it. So I’m asking here for an opinion or advice from someone who has faced similar situations and possibly found a solution.


We don’t get many enquiries about the 8000 any more as Denon DJ ended its production several years ago - but were kind enough to provide a free firmware update with new features several months after its production end.

The first thing to do is to save a couple of tunes onto a usb stick and pod them into the 8000 as a standalone device with no serato laptop connected.

Check the behaviour of the play and cue buttons on those files .

If it all works fine standalone but the buttons still play up in serato - then it’s probably the mapping file in serato

If the buttons play up the same whether you’re in serato or standalone mode then the buttons probably got excessive bashing and may need replacing.

As an interim thing, try turning on and off quantize that makes the buttons appear to “miss” their cues

1 Like

Sincerely Thank you! I tried it as you advised me, the controller works stable. Its buttons function perfectly when in standalone mode.

I know that the model of the controller is from about 6 years ago, but I ordered and bought it last week from a music store in Slovakia, as only “unboxed product”. However, when it arrived at my place I found that it was not in its own box, I didn’t have a Serato license key, it didn’t even have a cable to connect to a computer. But I really like this model, so I decided to try it. The store assures me that it has a “warranty”. That’s why I’m testing it.

Thanks again for your help, I’m really relieved and I’ll sleep peacefully :slight_smile: . I wish you all the best!

It works without a licence key for Serato DJ as the hardware unlocks Serato.

Are you on Mac or PC?

Can you record a video of what you are experiencing?

Head into Serato settings, go to the midi tab and uncheck Allow mapping

See if that helps

Otherwise reach out to Serato support

1 Like

I work at PC. But I guess a license key is required. When I registered the controller on the DENON DJ site and tried to Get a serial, it said: THERE IS NO SERIAL CODE LEFT, OR SERIAL CODE IS NOT FOUND. Today while I was working, after the standalone mode test, the problem still didn’t appear. When it happens again I will record a video. Later when I’m in front of the controller I’ll try what you told me.

Thank you for your response and advice!

you do not need a licence to use the mcx8000 with serato dj pro.

1 Like

Yes indeed, you were right, the controller activates Serato DJ automatically.

Here’s a link to the video of what’s happening:

This is what happens sometimes when I press the play/pause button. Whether from the left or the right, on the controller screens the track movement continues. In the serato, it stops at an exact position.

never seen that before.

good thing is that it is not affecting the audio/music

  1. what firmware do you have on the MCX8000?

  2. what version of serato dj?

I think you should let serato know about this

MCX8000 Latest Firmware v2.1

Now - Serato DJ Pro 3.0.1 But this thing also happened to Serato DJ Pro 2.4.6

You could try the 2.5 for the MCX8000

1 Like

My mistake, sorry. That’s the version Firmware v2.5 - up to date

HI, same problem for me on MCX8000… On my previous PC (with Serato 2.5.1), it could happen sometimes (very rare) . On/Off of the controller solved this problem. Now on my new PC and Serato 3, the problem is omnipresent… I think it’as a problem of USB controller. I’ll post if i find a solution.

Most likely you would be wrong. Easy to test: use the mcx8000 in standalone mode and see if it happens there.


OK, I remember now ! You have to download and install “Install_Denon_DJ_MCX8000_1.0.5” from denon site, and on Serato you go to Audio , click on Audio Panel (or something like this), and you put the minimum of latency. I tried it works. (sorry for my poor english ^^). Hope it will work

It happens to me daily. It doesn’t change my workflow (it doesn’t interfere), I started looking at the monitor more with serato open. This movement stops in the program itself. But really, when the controller is in standalone mode, there is no such problem.

As mentioned, that tells you it’s an issue with Serato. VDJ users did not report such problems. This needs to be raised with Serato as a bug report, probably something they did in the 3.x.x version that causes it.

1 Like

Did you try what i explained? (download Install_Denon_DJ_MCX8000_1.0.5 and put latency to miminum on Serato). When i put high latency, i’ve got the same problem as you. When i put low latency, all is ok.

1 Like

I will try this later today and post the result…

I have been with this Denon_DJ_MCX8000_1.0.5 driver since the beginning. I downloaded it from the DENON site, I haven’t used any other versions. I tried with reduced latency but it does these tricks again… When I try to change the latency in serato, however, it automatically opens the Denon DJ MCX8000 Control Panel. I changed it from there.

Sorry it didn’t work for you… Putting minimum latency resolved the problem for me. Hope you will find a solution.