MCX8000 2.0 firmware issue!

Hi, I upgraded my MCX8000 to V2.0 and my right hand side needle drop touch strip stopped working? Rolled back to v1.5 and it’s all OK again. It does it with Serato and USB drive. “Disable needle search during play back” is ticked in Serato (does It still when unticked)

I was not on the beta test. Anyone else having/seen this issue?

I’ve been waiting for this update and it works well apart from the above issue, so hope it s can be resolved??


1 Like

Not tried mine but I’m still getting screen freezes if I have display brightness on high. I literally only use cues pads & play/pause

No, sorry. Using firmware v2… Tried MCX8000 in standalone mode with USB - both drops worked. Connected to Serato and read music files from USB stick (connected to mac) and both drops worked. Is this the config. you were trying?

Hey @kev-n In regards to the screen freeze, have you contact technical support?

1 Like

Hi Chloe the screen freeze is a bit of a sore subject to be honest, my unit is now 6 months out of warranty. 2 weeks after warranty ran out i had to send the unit back to have the power switch sorted as it had stuck on which was kindly done free of charge as my warranty had just run out, but was advised if it had been any longer i would be charged. not sure what was done but the power switch was fixed (a component on the board was replaced) to fix this but they found another issue which required attention, which i was not told what that was but when i got it back i never suffered a screen freeze for 6-8 weeks then the freezes started again and have been an ongoing pain in the neck, i could understand it if i was using all the features and as tech support say to reduce the screen brightness, however the only features i ever use are play/pause, cue, pitch and cue points on the pads. the screen freeze is always the left hand screen and does it whilst using engine, serato or virtual dj. in firmware 1.5 i was running screen at 70% to prevent freezing i had to further reduce it to 60% after a period of time, now in version 2 in high brightness it still freezes so at present i’m running medium brightness, but i don’t know how long it will be before i need to reduce it to low.

1 Like

Email support directly, they may offer a good will fix for the screen freezing. You can never tell.

Be clear that you ve had the issue for long.

No harm in trying.

1 Like

Hey @kev-n was this our support team you contacted or the store you bought it from? We seem to be having a few 8000’s with screen freezes, so please do contact our support team & explain the issues you are having & they might be able to resolve this FOC


Hi Chloe yes it was sent back to denon for repair, i contacted service again when the freezes started and just got sent an email with loads of different settings to try, but as i was out of warranty it was a ‘chargeable’ repair which to be honest is a little out of order considering it’s a known issue. i will however contact support again and try to resolve this.

1 Like

Ah sorry to hear about this @kev-n Let me contact support for you. Can you private message me your contact details please & I’ll try get this resolved for you.


Continuing the discussion from MCX8000 2.0 firmware issue!:

Continuing the discussion from MCX8000 2.0 firmware issue!:

I’m having the same problem of @ kev-n @Chloe_DENONDJ, I’m in Panama, and here’s where I do not have technical support for these equipment, I worked well but the left screen is frozen and trngo equipped updated, MBP 15 16GB EL CAPITAN EP LAST VERSION AND MCX UPDATED MEMORIES KINGS … OF 64 ALL THE MUSIC ANALYZED e-mail WhatsApp 507 68143026

Ok, So I’ve now reinstalled serato pro and the MX8000 1.0.5 drivers. It’s all running on a i7/win10pro/16GB ram system and is ok when the MCX8000 has V1.5 firmware installed and has been since purchase. As soon as I install the V2.0 firmware my right hand side needle drop touch strip stops working? Roll back to v1.5 and its all OK again. It does it when using Serato and engine prepped USB drives. “Disable needle search during play back” is ticked in serato (does It still when unticked).

Any ideas? @Chloe_DENONDJ

just a thought when you update the firmware, do you put both mixer channels into engine whilst doing the update?

Thanks for your response @kev-n I did not think that would make any difference and it did not, but I still tried it as I desperate :slight_smile:

I now open a support call with Denon

1 Like

i only mentioned it as the update instructions clearly say that’s what you have to do

Thanks for your assistance Ken-n I’ve still got the issue and have no idea what this issue is…I’m following all of the instructions and the update works in every other way apart for the right hand needle drop strip ??

Hi @Chloe_DENONDJ I opened a support call on Saturday but as yet have had no response? Can you advise on how long it should take for someone to contact me?

Thank you :slight_smile:

I do apologise for the delay - please direct message me your contact details & I will contact our Service manager for you.

@Chloe_DENONDJ I’m unable to compose an email in my inbox? Is there a reason for this? Are there any restrictions in place as I’m new to the forum? Thanks

Hi @dgrav! Thanks for posting!

I will have someone from Technical Support reach out to you via e-mail to further assist. Thanks for your patience!