Macbook 2014 not recognize my controller

hello i have a retina i5 2014 macbook pro with Sierra and it not recognize my controller. i check usb port in settings and it finds mcx8000 but in audio section i not find anything. therefore i cant use my denon with virdauldj or another sw because when i open settings there is no mcx8000 for audio output. i tried changing ports (i have only 2 usb3) and cable and i also tried usb 2.0 hub but still have the same issue. my firmware is 1.5 (the last) and i already tried resetting factory settings. i dont know where to go. my denon is useless

I have A MacBook Pro (Retina, 13-inch, Late 2012) OS X Yosemite with 120GB SSD. There has only been problem once and it was when I used A USB cable of bad quality. I use one USB port on the Mac only for the controller and the other one for the external hard disk where I have my music library.


Thanks for posting. Sorry to hear you’re having issues with your MCX8000.

Have you tested your MCX8000 with another computer to see if the same thing happens?

You may find it helpful to create a new configuration in your Audio MIDI Setup. This may help if:

  • You have just updated your OS and your MIDI device is no longer recognized
  • Software cannot find your MIDI device
  • MIDI device is recognized by the software but has limited or no response
  • MIDI device was connected or disconnected repeatedly
  • MIDI device configuration has changed, i.e. USB keyboard is no longer a part of the setup and a new keyboard has been connected

Before getting started, disconnect all USB or Firewire MIDI devices or keyboards. This will eliminate any potential conflicts upon creating a new configuration.

Open the Audio/MIDI Setup by going to Applications > Utilities > Audio/MIDI Setup.

If the MIDI Studio window does not appear automatically, go to the menu bar at the top of the screen and select Window > Show MIDI Window.

The MIDI Studio window will pop and display all of your current MIDI devices.

You may see icons for all of your MIDI devices that have been “greyed out.” This just means that the devices are not currently connected. If a device is not connected to the computer but still appears connected in your MIDI Studio, that may be a part of the problem and a sign that the MIDI Studio needs to be reset.

Please Note: The IAC Driver and Network will always appear in the MIDI Studio.

To create a new configuration, click on the Configuration drop-down menu and select New Configuration…

Name the new configuration in the window that appears.

Click OK and the MIDI Studio will rescan your devices. If nothing is connected, only the IAC Driver and Network should appear again.

Starting with the device in question, re-connect each device one by one. Wait for the device to show up in the MIDI Studio before connecting the next one. Hint: you can also use the Rescan MIDI button at the top if a device is still not showing up while connected.

And that’s it!

Let me know how this goes!

1 Like

I have the same problem, my MacBook Pro don’t recognize the controller. I tried everything to fix and nothing yet.

MacbookPro 13 Retina OSX Sierra 10.12.3 MCX8000 firmware v1.5 Serato v1.9.6

I can’t work with my Denon yet, any solution available?

Hi DenonDJBill,

I am using an Imac (i think 2009) it runs with no problem. But i want to use my macbook pro (late 2013) and it does not recognise my brand new MCX8000. I followed your instructions in the post above. And is didn’t solve the problem. Is there anything els i can try?

I read about USB Hub or other cables. What do you think about that? I don’s wanna invest in all kinds of “possible” solutions.

With kind regards


Have you tried using another USB cable or port? What about another computer?

For the best performance, we recommend connecting directly to your computer’s USB port, as opposed to using a hub.

I fixed the problem using a tip from Apple. Pressing “option, control, R & P” at the same time while starting up my MBP reset the audio and it was done.

Thanks for posting back! Glad to hear you got this resolved! :slight_smile:

Could you be more specific please?? I’m having the same problem with mine


This what i found on an apple forum. It did the trick for me.

Now I have the sound working again by resetting the PRAM. Here’s how;

  1. Shut down your Mac.
  2. Locate the following keys on the keyboard: Command (⌘), Option, P, and R. You will need to hold these keys down simultaneously in step 4.
  3. Turn on the computer.
  4. Press and hold the Command-Option-P-R keys before the gray screen appears.
  5. Hold the keys down until the computer restarts and you hear the startup sound for the second time. Release the keys.

It’s telling me to reinstall MacOS Sierra. Did it erase everything in my computer?

That didn’t work. I got the brand new Mac book.

Oh I’m sorry. It worked out fine for me and for mij MBP (late 2013).

This is the link i found.

hi there, thanks for help. i reset the pram as suggest, but it not works. my macbook is already formatted and brand new installed but still have the same issues with recognizing the denon controller