Loaded RekordBox drive on SC6000, one works perfect, the other doesn't show waveforms

  • I exported my RekordBox library to a thumb drive and placed it directly into my new, recently updated, SC6000
  • Deck A recognized the RB library, loaded it, and works as expected
  • Deck B sees the thumb drive and the tracks; however, when loading songs the waveforms do not render.
  • I can play the track, but I can’t adjust the pitch, edit the beat grid, do anything outside of simply hitting play on letting it play at the default tempo
  • Both decks are connected to my 1850 mixer, which is also connected to the my LAN via the computer ethernet port

Anyone seen this happen before? Running RB on an M1 Mac, latest version of everything.


Did You let the rekorbox database from usb to be read by the player?

Yeah, just did an export from RB to my thumbdrive, then threw it in Deck A. It read the tracks, they worked as expected. Deck B saw the thumb drive and loads the track list but when one is loaded, the above behavior occurs. I tried rebooting the deck, loaded up tracks from beatport which worked fined, and tried again, no luck :frowning:

I then cleared the drive, imported the RB library into Engine, then exported from Engine to the thumb, worked as expected on both decks.

It’s not the worst problem in the world but it seems like a bug that should be reported. Engine is cool and all, but I wanna limit the number of DJ library tools to 1 if possible and given that most venues are still Pioneer, RB might be it

Hm… I would try to make another usb stick from RB and try to use it on the second player. Maybe just make a copy of the previous one. Also try to use that usb on the “faulty” deck directly maybe…?