Kill vs Bleed Option issue w/Filter

Hi all, While playing around with my Prime 4… I came across the “Kill” & “Bleed” option under the settings menu… Very nice to have this Sweep Filter option…

What i noticed though… Is that “Bleed” (when selected) works on all Sweep FX 100% correctly except for “Filter”… When “Filter” is selected… “Bleed” works as it should when turning the Sweep FX knob to the Left… But when i turn the Sweep FX knob to the Right it goes straight to “Kill”… It is not functioning properly.

What firmware version have you installed?

This is still an issue on 2.2.0.

When you check the filter operation, do you use your headphones to listen, or do you listen through the external amplification system?

I’ll check if this happens to me too and let you know.

The filter can kill when set to bleed if the track does not contain any frequencies above the high pass frequency of the filter. For example very low quality mp3 will always get kill, when there is no audio information above 16 or 12 KHz, and filter cuts to 16KHz… for example.


@NoiseRiser makes perfect sense… if there is nothing to bleed then it will kill it.

1 Like

Yes, this makes sense… But why have a bleed vs kill filter if bleed still kills?? Unfortunately, out of my 44,000 plus files i still have to manually stop bleed fx knob at about 3/4 of the way to the right to have the high frequency bleed effect. Perhaps an adjustable high frequency roll off can be added under settings to make this adjustment more effective?

As said, if the file is not having anything happening above the cut off frequency it will not bleed. What files are You using? What is the beat rate?

Hi, I am using high quality mp3’s… Is everyone else here actually getting bleed to work when turned all the way to the right on their high quality files?? Of all my high quality bit rate files (and some lower) i cannot seem to meet the high frequency cutoff that allows for bleed at a full turn to the right of the fx knob. If this is the way it is so be it. I just wished it was consistent Bleed. As i can already use Kill in either direction with less rotation and obtain a similar Bleed.:man_shrugging:

Ahhhhhhh. You say high quality. But how were these compiled into high quality. Did you rip the cd. Or ard they from another source, that could be that domeone has taken a 128bitrate file and expanded it to 320bitrate. It will still have a cutoff rate of the 128 you cant add info to an mp3. Once its downgraded its downgraded nothing will bring it back.up hence the “lossy” tag. If however they are say flac files then run them through an analyzer to see where the cutoff range is. Its possible the the “top end” actually cuts off lower than you think

Thank you… I will check that out… BTW… I am going to send you a private message… Hopefully it will help you out regarding another post.

:+1::+1::+1:. Not for me but cheers.

My bad, i just messaged the poster…

Well, I use streaming services for some time, and I think, that the quality of these files is definitely not the highest, but I still get a bleed on the filter sweep if set to bleed. As @Dj-alzy said, try to run the analysis of the frequency spectrum of your files. Maybe they have a high frequency roll off encoded very low.

@jnyvio As I promised, I did the verification on my Prime 4 with firmware 2.2.0.

The filter works regularly, both with bleed and kill settings, and even when using MP3s at 128 kbps (so more than quality it is important that the frequencies of the two outer edges of the filter are present in the track being listened to, otherwise you will not hear any difference between the two mode).

I was explaining this also… If there is no audible information above the cut off frequency, there will be nothing heard…

1 Like