Issues caused by poor grounding in Prime 4?

Hi All,

I purchased my Prime 4 from Long & McQuade in Canada in July '21, and I’ve been having a few issues with the controller. I have reached out directly to Denon support via their website TWICE now, without any response, so now I’m posting here. Hopefully someone from Denon will see this and can help me out. I’d like to have a properly working controller before our wedding season starts.

Here are my issues:

1 - The LED ring around the left jog wheel will sometimes flicker if the unit has sat for awhile without being used. Almost like it tried to enter a sleep mode, but as far as I know there isn’t a sleep mode in the Prime 4. The issue is intermittent in nature.

2 - Cue buttons will sometimes stop working. This issue is odd, intermittent, and transient and it is my biggest complaint about the unit right now. When the issue started happening the cue button on the right deck would not function to bring the track back to the last hot cue or cue point set, but it would lay a flag on the track at the point the cue button was hit. The problem was exclusive to the right deck for many weeks - I never had a problem with the left deck cue button… until I did. Then the problem was exclusive to the left deck for many weeks. And now the problem has moved back to the right deck. This issue doesn’t happen with every set - sometimes I can mix every day for a week without any issues at all and then it starts happening again. Sometimes it happens right from the first track I play and resetting the controller doesn’t solve anything. Other times it crops up mid-set and is there for the remainder of my set. And sometimes the issue comes and goes throughout the set. And like I said - it’s always the same cue button that gives me a hard time - until the issue moves to the other cue button.

3 - Vinyl mode doesn’t work on either deck. The button lights up, but putting my hand on top of the jog wheel doesn’t stop the track, and moving the jog wheel behaves in exactly the same manner as I’d expect with Vinyl mode turned off. The protective shipping plastic is removed from the jog wheels, so that’s not a factor here. I’m not sure if this ever worked since I bought the controller, I never really tried it out until recently, but it definitely is not working at this time.

The controller is on Engine OS 2.1.0 and all of these issues do seem electrical in nature - specifically they’re the kind of thing I’d expect to possibly see if we had a bad ground, so I suspect they’re related to a common source. I’m no electrician, but I am a seasoned pro, so the obvious first things I’ve done is check the ground at the wall with a circuit tester (GOOD), and swap the power cable. Neither option has improved my situation, so if it is a ground issue it seems like it’s internal to the controller.

I’ve tried to be thorough in my documentation of these issues. I’m definitely open to other troubleshooting steps, if any, that could help diagnose the issue.

Thank you in advance for reading and I look forward to your support!

1 Like

I meant to be thorough, but there is actually one more issue I’m having with the Prime 4 that may or may not be related to the above issues.

4 - I have installed a 120GB SSD in the slot in the bottom of the controller. I’ve formatted the drive as both FAT32 and ExFat, but the Prime 4 always tells me that the drive is incompatible and needs to be reformatted.

Okay - I think that’s the end of my laundry list!


Have you tried to remove the SSD from the Prime 4 and perform a reboot by holding the “eject” key and without releasing press “power”, you will have the chip to be able to perform a new installation of Engine Os?

Then try the P4 with an external USB key / SD card (in Exfat format if the key or SD card is larger than 32gb) to see if the problem is still present?

do you have electric heaters nearby or neon lights, or appliances with switching power supplies or an energy accumulator ???

We are many users having this king of issues on P4 since 2.1 update.

I have a desktop PC in the space, but otherwise no electric heaters, neon lights, or other appliances. Even with all other equipment off, the unit behaves the same.

I removed the SSD from the Prime 4 and rebooted the unit while holding down the eject key. It doesn’t seem to have done anything special, so I don’t know what that should have accomplished. Can you explain further?

I put a 64GB SD card in the slot, and I’m hearing some crackling type static from the left deck.

I did discover that the vinyl mode does work on the left deck - but only if the LED ring is flickering…however, if the LED ring is flickering the left deck plays very slow and with a lot of static type crackling sounds.

This gets more and more troubling as I go.

Sorry to hear that - however I was having these issues before updating to 2.1.0.

I have now updated to 2.1.1 since I wrote my original post and if anything the issues have become worse.

I believe I figured out what you were telling me to do - I ended up taking the Prime 4 back to 1.6.2. The issues remained. I’ve now gone back to 2.1.1 - and yes the issues are still there.

What is strange is that we will say that the installation is partially done! At the end of the extraction of the files with the installation utility, the P4 is supposed to take over. So there, it works almost directly to the insertion of a USB key. The installation must have:

1- extraction of files with the installer (Windows App Or OS App)

2- End of the extraction (the application indicates DONE)

3- The prime4 installs the files the leds of the controller light up from left to right, the installation takes well over a minute including the update of the various elements of the P4 “decks and mixing…”.

4- End of installation the Prime4 turns off

5- Switching on the Prime4 (indicating Engine OS 2.1.1) then accessing the various menus

Update Denon Prime 4

Maybe your SSD is being formatted with a GPT partiton table? must be MBR/FAT32 or MBR/Exfat

Could be this - I did delete all partitions off the drive and reformat, and still get the error. I’ll have to look into this part of the list further.

I still think I have a major hardware malfunction otherwise. So many issues.

When installing the firmware (OS) of the Denon P4 were identical to my video that I attached in my previous com ???

Yes it was the same process, except on PC.

OK, bad luck! :pensive: Maybe a badly connected internal cable ??? :thinking:

Personally I would’ve returned the unit for a new one. Sounds like it’s got an internal fault.

This is the route I’m chasing right now.

Hey @DanceShout Happy to look into this for you. Can you share your email and phone number with us so we can have a technical support agent take a look?

Thanks - I’ve sent you a DM with those details

1 Like

@DanceShout I’m having similar issues. Have my prime 4 nearly 2 years and only used it about 10 times. Did you have any luck sorting your problems?

Sent my unit for repair at the beginning of February and haven’t seen it since. It’s anybody’s guess right now lol

Hey @Patrick_Ahern - If you’re experiencing issues with the hardware, I would suggest contacting our technical support team and creating a ticket so they can take a closer look. You can create a ticket via