Issue with reading a USB Stick

So I have transferred all of my music using engine onto a USB3.0 128GB USB flash drive which is formatted to FAT32.

I can see all of the music on the drive and it seems to be in the readable Engine format. However when I plug the drive into the MCX8000 it reads the flash drive but does not find any media on the drive.

The MCX8000 is on the latest version of firmware and I have used Engine 1.5

Anyone else had issues or know how to resolve this?

Try formatting the USB drive in the MCx8000 FIRST. After that plug your drive into your computer, analyze all your music in Engine 1.5.2 and drag it from Engine into the USB playlist folder(bottom left hand side of the Engine software).

There is no option within the MXC8000 to format a USB stick

Ok so it seems the original tool I used for Formatting the drive to Fat32 didn’t do a good enough job.

So I used this tool Format Fat32 Program

To format my drive and Now I can read files directly off of the USB stick

Did a Quick test with Engine and this is also good.

Issue resolved.

1 Like

Glad to hear it, Jonny! Please post back if anything else surfaces–I’ll be happy to help.

Hi, does anyone know why I can not get my MCX8000 work with external HDD larger than 128 GB? I have the latest firmware and HDD (750GB) formatted to FAT32.

Hi is it a hard drive or a USB flash drive/ memory stick / thumb drive?

If hard drive, is it powered by a proper power supply from a wall outlet or trying to run from USB power only?

Does the device suggest it has encryption eg: “data vault” , “secure travels” ? Such devices load a special PC and Mac driver which handles the decryption - but of course a media player can’t read that decryption file so won’t be able to see the data properly either.

When plugged into a PC, does the drive show itself just as one big drive letter or two (or more? Also, when plugged into PC , does any pop welcome screen or pop up splash screen appear briefly? (Not just theusual windows “I see a new USB device” message. If so, you may only be formatting a particular partition on the drive, rather than formatting the drive itself. Some such partitions and software can only be removed using a small, free app downloadable from the drive manufacturers website - sometimes called a drive utility or deep formatted.

From what I can tell (and this is not a denon issue) USB HDD act differently to Flash drives in the fact they require inbuilt driver / controllers (normally built into windows / Mac OS X).

Flash drives don’t require these so will work.

Ive had a 2TB hard drive plugged into the 8000 for several months without issue. There are many different quirks and oddities on different drives and memory sticks for that matter. In the past, drives with extra “stuff” on them have proved troublesome / eg: one button back up , multiple ports, NAS boxes, cloud central drives etc

Also try what I found. Use the tool I linked to download and format the drive with proper fat32 as windows will not format to a correct fat32 drive and other tools won’t either so try the link I posted in this thread and see if it can read the drive then.

OMFG, I almost pulled my hair out on the Prime 4. Same issue, new USB stick did not get recognized even though it powered up. The link provided saved the day. Old tool worked where nothing else did to allow the new stick to work.

Originally tried different ports, normal reformat with Win10, even alternated between fat32 and exfat.