Issue when scratching after update

Hello all

need some help

I have just a update and on the left hand deck (1&3) if I try scratch on any beat it just backwards of the beat I am trying to hold.

Right hand deck (2&4) is performing perfectly.

please advice

1 Like

Hello Aposegil,

Sorry to hear you’re having issues. Can you give a bit more detail on the issue you are seeing. Can you answer the following questions:

  • What software are you running in combination with your MC700?
  • What is your OS?
  • What did you update? Was it the MC7000 firmware, the OS or the newest version of your DJ software?
  • Would it possible to record a video of what you are seeing? If not, can you give actual steps to reproduce ie: Step 1: Load track. Step 2: Press Play. Step 3 Scratch backwards. Result: No scratch.

With that, we will have a better chance of getting you sorted out.



1 Like

I’m having similar issues. It seems like it happened after I updated the firmware on the MC7000. When I try to scratch, the jog wheels behave like cdj mode, you can slow or make song faster but can’t scratch at all.

I’m running the latest version of Serato on OS X Yosemite.

please advice Vince.

1 Like


it seems like i´m not the only one with this problem. i noticed that issue a few weeks ago. also udgradet the firmware 1.2 arround 1,5 month ago. the issue is only on the right deck. vinyl mode activated. preview firmware version no problems. i thought this is maybe a hardware problem… left deck without any issue.

im running mcos sierra 10.12.6. with the latest version of serato dj pro.

i will try to give you a quick issue report… when the track is loaded at the first cue point and it is paused, sometimes the scratch mode is wotking and sometimes not. so i have to press the cue button and try it again.

when the track is playing, scratching is most of the time not possible. so i have to touch the jog wheel more often that it works sometime.

now i set the intense in the new setting mode to 1+. maybe it works.

please check the problem as soon as possible!!! thanks

1 Like

reply i am having the same issues its on my left deck when i move the jog wheel fwd it drags the song back very frustrating this has to be a known issues that needs a fix

update here is video

1 Like

Hi Guys,

Sorry to hear of the difficulty with the latest update. Have you checked your platter sensitivity setting in the new Hardware Settings Mode? It sounds like the sensitivity of one of the decks is less than the other.

To Enter This Mode: Power on the MC7000 while holding BACK and PANEL for 2 seconds on either deck.

Make sure you check both left and right deck settings. Hopefully this helps!

1 Like

=okay i tried adjusting the platter sensitivity and it did not work, i went from default to +1 to +3 and it made no difference. the problem was not resolved

1 Like

Good Afternoon,

My issue is the exact same as djccruz with the exception that the issues are intermittent (on either deck)…

  • When I try to scratch, the platter behaves like it’s in cdj mode; it will pitch bend the song to make it slower or faster but you can not scratch at all.
  • When I have the song “paused” and I try to use the platter to fine cue, it just drags the song real slow.
  • I have also run into an issue where pushing the PLAY BUTTON will not play the song but it will light the PLAY BUTTON “>” & the SYNC BUTTON in Serato DJ (now this a HUGE problem!!!)

I feel as if my issues started shortly after upgrading the MC7000’s firmware.

This situation needs to get rectified as soon as possible. Can you imagine the disaster a DJ encounters when you’re at wedding, have cue’d up the first dance but the song won’t play when you hit the PLAY BUTTON? Let me tell you… It is not a cute position to be in. I wouldn’t wish it on anybody.


Same problem for me. right platter work good, scratching on left platter works sometimes. when will that be solved?

1 Like

Hey Jaydax,

Did you adjust the calibration as suggested above?

1 Like

Hey @DiverseEnt,

Im also a wedding DJ currently using the MC7000. The issues you described above all seem to relate to the platter sensitivity. Have you tried to adjust your settings as I described above?

The reason the play button didn’t work is likely because the platter detected a false touch.

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.