Internal SSD Drive issue

Hi all. I purchased a 1tb SSD but formatted, transfered music using an SSD case I’ve had. Everything is fine if I use the SSD with my case and connected to USB but when I installed my SSD internally, everything freezes. I can see all my music but everything lights up and is non functional. Do I need to reformat the SSD and install internally and connect via blue USB cable or is there another fix? Thank you in advance for any help.


Did you prepare the drive with MBR and ExFAT?

Generally speaking with a drive that is going to be used internally, is to format it while connected where it will end up. The exception: if you clone an external drive (for example SSD) from your laptops HD (usually won’t fit two) and then remove the SSD from the external case and swap out the laptop HD. In this case both disks are (pretty much) bit-for-bit identical and there will be no problems.

I can answer this as I’ve just had exactly the same problem!!

Format it as ExFAT. That works. FAT32 doesn’t work when plugged in the SATA underneath the unit.

FAT32 freezes the unit as you described. ExFAT doesn’t. I think it might be due to the controller chips for USB & SATA, that’s why it works when plugged into USB, but doesn’t work via SATA.

ExFAT is the answer my friend :smiley:

1 Like

Thanks all for the quick responses. You were right on I formatted it as FAT32 not ExFAT. Oh well you live and you learn. Not looking forward to formatting and loading my collection again but a DJ’s gotta what a DJ’s gotta do :fist:t3:

I’ve already sent Denon a PM explaining that this is going to catch a lot of people out, and they’ll have a lot of returns (I almost returned mine!) unless they edit the FAQ and manual to expressly select ExFAT for the internal SSD. USB drives are fine as FAT32, just not the internal SSD.

Absolutely agree. Great advice, wasn’t going to return mine but was ready to call for exchange for defective unit. Thanks again for the advice.

1 Like

Copy all to another location or drive. Format again and copy all back.

Hi guys, I was just testing my P4 with installed SSD 1TB SAMSUNG, ex fat formatted as denon said to do, loaded it with a few Playlists and about at half an hour using it, the ssd desapeared from the library… No source found… reboot several times, didn’t work. Controller mode, didn’t show ssd on my mac… wha t should I do?

Do you have a chance to take it out and connect it externally. If it doesn’t show up there you might have a faulty drive.

Hi, that’s what it looks like… I’ve tried as external and no show… Also tried to connect to my Mac and no show…

Thank you for your help.

I went the the SSD seller for testing the drive and it is ok (My cable case for external connection wasn’t compatible). I’ve connected again to my Win PC and it Some Erros needing correction, So I did and will try again on Prime 4… Let’s hope…

Hi, I installed the SSD like Denon video, After 2 hours successful use, my Samsung QVO 1TB SSD desapeared from source. I rebooted several times, no success. I Went to SSD seller to test the unit, it is ok. I bought a external case for SSD and it works on my Win PC, on Mac Laptop, and also as external USB on Prime4. I tried again on SATA bay, no show. I formated the SDD again (both Exfat and Fat32) connecting direct to my Mac, the tried again on P4 SATA bay and no show. Also tried several times to instal and format again following Denon video but it does not show on Mac. I can I do? The problem seems to be only around the Sata bay on P4.

Please help! Thanx. Renato

Did you use GUID or MBR when formatting the drive?

Think I read somewhere that MBR is preferred for the P4. I could be wrong though.

I think was GUID by default. Anyway what is that? Thanx

Yes, in my testing it has to be MBR + ExFat format for the internal SSD.

1 Like

Try MBR. Master Boot Record

In Disk utility when selecting how to format the SSD u will see a drop menu below ExFat/Fat

On the Mojave version of Disk Utility, annoyingly, you don’t see that option! As memory serves you have to go to the View menu, select something like show volumes, then select the SSD on the left hand side and THEN you’ll see the MBR option. That’s from memory though and I’m typing this quick reply from work, so Google it and it’ll tell you exactly how to show the MBR option!

1 Like

I have High Sierra, can’t see GUID / MBR option…

Sorry, I found it! let’s try…