I wanna downgrade my prime 4 to 1.5.2 or older, anyone still have backup link or file?

My prime 4 update from 1.3.2 to 1.6.2 today via Mac but got shutdown after i click Done on Mac. then i tried to turn P4 on after few minutes but it’s still show on updating then auto shutdown after like 10 sec. I did downgrade to 1.6.1 but did not work, then 1.6.0 and it only can use screen (buttons are not working). So can you guys please send me the older version like 1.5.2 or even older like 1.4? i wanna try out if they can make my prime 4 work again. Thanks.

This sounds like the issue I had when I tried to update from 1.4.1 to 1.6.2. If you do get a copy of 1.5 and it works then I’d really like to know. My Prime 4 has been unusable since I updated.

Have you tried to force firmware in usb mode? Download and unzip the fw, and put it on the root of a usb stick Turn off unit, plug stick in, press and hold load < and load > Turn on unit holding those buttons it will get in usb update mode

Don’t downgrade from 1.6 as there was an issue that is irreversible. This is why the firmware was removed from the downloads section.

If there is an issue with your current firmware then you need to reload it by forcing the firmware to update again.

1 Like

sound great, i’ll try and report to you guy asap

Hey @DjSWG - Sorry to hear you’re running into some issues. As some users have mentioned, we don’t recommend downgrading in order to upgrade. This can cause some issues. We highly suggest connecting with a technical support agent to receive some consultation on how to properly install 1.6.2.

Can you DM me your information so I can connect you with one? (name, email, number)

1 Like

hi @rcatelli , i did what you tell me but unit can’t get into usb update mode.

What @rcatelli told you is for the PrimeGO. :relieved:

Prime4 procedure is holding EJECT while powering ON.

1 Like

@Reese @DjSWG sorry for the wrong info!


thanks for advice. but still the same. i think it’s all about Firmware problem. P4 still auto shutdown after few seconds

I would suggest to DM @Anthony_DDJ to get techsupport have a look at it.

1 Like

just DM you sir.

1 Like

O wouls llove your input experiencing the same problem…

it’s me, again. After many tries and i just found that my Prime 4 can’t use in other firmware but 1.3.2 (factory). now and wanna go back to 1.3.2. wonder if anyone still keep that file?

Factory wasn’t a downloadable file if I remember. It was only the subsequent updates that was.

Also, did you spot the post a few up? Downgrading anything below 1.6 causes irreversible issues so they removed them from the website. If you attempt to load one lower than that then it’s not recommended.

If there’s a problem with the unit then it may need servicing or a technician can help get the correct firmware installed. A brand new quality USB formatted in FAT32 would work okay.

1 Like