Hot cues not working in hybrid SSL w/pwrd usb hub? (Solved)


So I got my 3900’s working great last night in hybrid mode with serato scratch live including the hot cues, today I attached a powered usb drive to the system and like i read i put the 2 decks into it and left the main usb from my serato box going into the laptop and I lose the ability to use the hot cues and I guess a lot of the other midi mapped controls like select etc. I put the usb’s back into the computer and I got the hot cues back again?

It’s a powered hub (as reccomended) using a plug (not usb cable) though I notice is says the power only kicks in when the voltage goes below a certain rating. Surely this can’t be the reason I’m losing the hot cues? For the record the pitch still works fine. I really need 4 usb inputs and there are only 3 on the laptop, that’s the reason for reluctantly using the hub, my usb keyring holds my library hence the need for a 4th input. Any pointers would be apreciated please.

thanks. Sean


I’d try numbering the USB ports on the lappy and try powering up everything with different things in different ports…make a list of each combo

Disable any sort of power/port control in the lappys operating system (advanced power settings)

Try a different behaving powered hub

Try an alternative USB storage device - some of the dandy shaped/novelty ones don’t always conform to USB standards


I would try a different hub (one that is always fully powered).


dont use cheap powered usb … get a belkin… been using belkin for a few years with my mc6000 and 2 3700 with ssl


Resolved! it worked perfectly with a powered belkin hub. Thanks :slight_smile: