Headphone and output out of sync

hi, can anyone help. Maybe I’m missing a setting but when I’m trying to to mix the track from the headphones is out of sync with the main outputs. When it comes to mixing im quite old skool in the sense I mix using ears and not just looking at bpm. Anyway I’ve noticed the prime 4 when I’ve matched the beat via sound with headphones and output and it sounds match when I go to the cueing track in the the live mix the sound is out and the new track I just put into the mix although beat matches is slightly behind and tho the is a slight delay from headphone to master out.

I’m using Standered Phillips headphones with the 3.5mm jack and xlr to rca into my stereo. I vae tried on both master out and booth and the delay is still there so I’m not sure what it is. Can anyone help please is I dont understand it


1 Like

This issue has nothing to do with Prime 4 but with your stereo. Try to disable any kind of DSP preset on it, music mode and enable bypass.


Also check that the stereos speakers are wired speakers not Bluetooth etc, which also adds a layer of latency

And don’t forget that distance from speaker to ear = latency. And this starts to be an issue sooner than you think. It’s why DJ’s use booth monitors or in-headphone mixing.

My three cents as usual

1 Like

My speakers are at my feet but I still find tiny little beat of beat latency. I thought it was just me, but there is definitely latency when there shouldn’t be. I use xlr straight into denon sm speakers.

At about 6 ft height, delay from the floor would be somewhere in the 5,5 to 6 ms range. Typically that should not be audible if your mix sounds right. What you can do is go to split cue, line up the mix, then take off your headphones and see if it also comes out of your speakers correct.

I mean it’s not a HUGE issue I’ve played live in clubs I can work with what I’ve got. I only mentioned it to confirm what that other person was saying.

Could it be that he’s using auto-sync and the beat grid is “off” by a 100ms or so ? In that case of sliding the Beatgrid left/right might help

Not using auto sync and my speakers are on a foot away from may face. And they are not blutooth

Are you saying that the headphone sound is delayed, or the speaker sound is delayed?

What make/model is the “stereo”?

I’d change the headphones to any other wired headphones (not Bluetooth or wireless)

And change the speaker / hifi that you’re using OMG to listen to the main output. As someone else said above, the hifi might be adding some delay because due to a DSP chip for spatial or loudness or some such other reason

Also having this issue. I have no settings like loudness or surround sound or anything like that on my stereo but the sound coming from the stereo is about half a second delayed from what’s coming from the headphones. I have to start my mix in my earphones then take them completely off and finish it on the speakers.

Its really winding me up cos my headphones are dennon hp1100 and my stereo is a Samsung. Of which I have used many different mixers on and never had that problem but yet the prime 4 as this weird delay thing and my stereo have no presets turned on and the speakers are no more the 2ft away from my face. I just dont get where the latency is coming from other than maybe a software issue. And if it is the god knows when the next prime 4 update is??? By the way I’m running update 1.4.1

Some stereos have a built in DSP that is not possible to bypass. Tough luck if that is your case.

Just test with any cheap PC speakers and you will straight away know if the problem is in the Prime4 or your stereo.

1 Like
  I am having the same issues. RCA cables from Main Output to Mini headphone jack to a BOSE powered shelf speaker. 
 Any recommendations?

Is there a delay or echo etc that could be left on by a user.

It would actually need £circuitry do add a delay to the main output.

Are you passing the sound out via a commercial hifi , Bluetooth speaker , Sound bar , smart speakers etc -? All those things and More can add delay to audio

Get rid of shitty Bose speakers that are not meant for DJing.

I have exactly the same issue with my Prime 2, and before you say its my setup, it didn’t do it with my XDJ RX2 or DDJ800.

I’m confused how it can be different to the audio output, i thought they ran through the same board :thinking:.

The daft thing is, when I go in to controller mode, and run Virtual DJ, it sounds correct again. W.T.F…! :person_shrugging: