Firmware Version "UPDATE AVAILABLE" even though already updated to most up-to-date firmware 1.2.2

Hello – SC5000 keeps displaying Firmware Version message that reads “UPDATE AVAILABLE” for 1.2.2 even though the latest firmware 1.2.2 is already installed. Please advise if there’s something wrong here or how to get this message to go away. Thank you.

Could you make a screen photo where and how you see this?

1 Like

What’s also not making any sense is the “REMIND LATER” and “IGNORE” options. There’s not a discernible difference between these two options. Pressing either one simply makes popup go away and returns to screen underneath it, but nothing ever changes. The firmware “UPDATE AVAILABLE” notice never goes away.

Weird. Mine is clearly the same build and connected to the internet through the X1800 mixer’s network switch.

When I check, it comes back with “already up to date”. Maybe someone from staff can answer this.

This is odd. Are you getting this when you don’t have a drive connected?

It’s possible that there’s something funny going on in your drive. You can try deleting the “version” file in your drive’s Engine Library folder and see if it helps. This will be re-created when you plug it back into Engine Prime, but maybe this will fix the issue.

Correct, what’s shown above is without any drives or computer connected, just power cable. What should I do to resolve issue?

I would suggest trying to flash it again with 1.2.2. But since I’m not aware of another instance of this happening, I can’t promise that it would fix it.

Can I reinstall 1.2.2 directly from a USB flashdrive, or do I need to do it via computer like what originally needed to be done fresh from factory?

You can do it from a flash drive. 1.2 and above is capable of updating over drives.

Still no luck. Just reinstalled 1.2.2 firmware via USB and still get same messages described in OP. Please see video linked here that illustrates issue we’re experiencing and advise next steps. Thank you.


Make a Try: Take a other USB Stick, format it, in Engine add a couple of songs on it and try it again?

I update always via the front usb 2.0 and did not test with the back usb.

Will try that. Thanks.

Will try that as well (thanks), but what is the difference between front 1X USB location and rear 2X USB location? Is the front USB somehow dedicated strictly to firmware updates for some reason?

No indication that a port is for firmware.

Only differences are:

Back USB’s are all 3.0. Front is only 2.0.

For me it’s better accessible at the front so never tried the other ports (other than the computer USB port).

Did my 1.2.2 update with the rear USB port using a USB 3.1 thumb drive. No issues.

hello I have the same problem … have you found any solution? the network connection works?

Denon DJ technical support has messaged me directly stating “The firmware update message will more than likely be resolved with a future update when it is available.”


ok, thanks … but are you giving other problems?

“giving other problems”? – Sorry, not understanding what you’re asking. I’m not giving any problems that I’m aware of, but Denon is, specifically the problem described in OP and demonstrated in video linked earlier.

My unit also displays “UPDATE AVAILABLE” for version 1.3.1 even though I have the latest firmware as well. This is with the SC5000 not connected to any drives. This is strange because I have 3 SC5000’s and they were all updated the same way on the same day, but only one displays “UPDATE AVAILABLE” while the others display “CHECK FOR UPDATES”. Weird!

1 Like