Firmware update stuck

Dear all, I need help, my Denon MCX8000 is stuck in the process of updating firmware. See the picture attached. Thanks for your support. Alex! IMG_20191022_105617|375x500

Hi @haDJi I have the same problem… please tell me if you could solve it… Regards


A couple of questions to see if I can help you

1 -What firmware version did you have before?

2- Which firmware version are you trying to install

I ask why a big jump between versions can give these problems, even skipping an intermediate update in some cases, I don’t know if you saw the emergency update procedure

1.Place a USB drive that contains the latest firmware update package into USB 1.

Power on the MCX8000.

The left deck Cue button will flash. Press the Cue button.

The left deck Sync button will flash. This indicates the unit is updating.

When the left deck Play button is lit solid green the update is complete.

Turn the MCX8000 off, count to 4, then turn it back on again.

Try to go back to the version you had before first


Hi @El_Corsario, yes i saw before this procedure. I don’t know if my mcx8000 does not have this function because any light is flashing after turn on the console (step 2).

The versión i tried to install was the 2.1. This is my situation now. Regards!


Which version did you have previously 1.5 or 2.0, if it was 1.5 try to install the 2.0 first since this has great changes and the 2.1 is only an update to correct bugs of the 2.0 if you manage to do this later you can upload to 2.1


Dear all, Well I don’t know if I am a lucky one but my problem is solved. What I did, I used another empty usb stick of 8giga (FAT 32 formatted of course), I uploaded the MCX8000_Firmware_v2.1.bin on it and after that inserted in the USB1 slot of the MXC8000. Powered ON the Denon and then instant it began to continue the update of the firmware. Mine had the engine completed and the other missing so it continued to upload from the Display Assets and then the rest to finally reboot and everything was ok. I know in this kind of thing, if the update of the firmware doesn’t go right, you usually end up with changing the motherboard, and in our case it’s 250 EUR for the Denon MCX8000. So I hope that @jcazalw got lucky like me and can continue the update of the firmware. I am not sure what firmware I had before, what I can tell you is that I bought is one year ago and never updated it from then. Good Luck!

Thank you @haDJi! Congratulations!!!

@El_Corsario i will try your suggestions…

@jcazalw I just saw in detail your pictures, you had exactly the same problem like me. Change the usb stick, I don’t think it counts but I uploaded the firmware on a Sandisk Cruzer Facet 8 Giga USB stick which was formatted from factory and never touched it. The first USB stick was a 16 giga Sandisk Cruzer Contour but was formatted many times before in FAT32 via Mac or Windows.

I have changed USB sticks 3x and it wasnt help now im trying instal firmware 2.0 and its still the same