Fail to record prime 4

At some point while I’m recording my set , it comes out an error that the speed is too slow . It never happen before and I’m using the same usb as before . Any suggestions?

1 Like

Something has happened to the memory stick state if it’s that exact stick you’ve used successfully before. Not just same outside brand Make and model.

I have two Sticks, both branded at sandisk and one is much faster than the other so maybe sandisk use different chips within if they get some chips more easily than others. You know the usual “we reserve the right to change”. As memory sticks are only sold on capacity, rather than speed, I can’t really send it back to them as it does what it says it does : it holds 64gb of data

SD cards are a bit of a step up in that sense. sD cards are dated in two ways, their capacity And also their speed, so they have to be a certain speed to be what they say they’ll be.

You could try defraging the stick and removing all other files from it first including trash. “ Deleted” files aren’t really deleted, they’re just flagged with a deleted flag telling OS that it’s ok to write over that space. Maybe that “ok to write here” takes a few milliseconds and trips the sticks speed. And like if the recording has to be saved into hundreds of tiny fragmented spaces in between other files, maybe that takes longer to write than a single big space. Or maybe the stick has some bad chips/sectors etc

Of course we aren’t told by the prime 4 exactly how fast or slow or more importantly how close the recording came before to not working. Like if the speed has to be over 500 and the stick manages 501 when empty and working well, that’s a very close margin to failing.

Also, are you using the same stick to record to as your searching and playing from?

Hello guys. Thanks for the answer.

It took time to reply cause I ordered a super fast USB CORSAIR, that arrived yesterday. I put some files on it, and I tried to play and record. Nada. Once again after a while (longer than before) it stops to record … again same issue cause it was saying too slow.

Yes I’m using the same USB to record and play from.

But I tried to add another USB and recording separately but the second USB won’t read or at least I can’t find a way to decide to record on the second USB.

It’s quite frustrating since I was very inspired yesterday :laughing:

Any idea how to solve the issue?


Are you recording to the same drive you’re playing off? If so try playing and recording to different drives.

1 Like

Merging here. Editing to make it readable. One moment…

1 Like


It’s the latest version of Denon Prime 4 Firmware that’s the issue. Denon needs to look into this and fix it, but for now:

Don’t use 1.4.1.

  1. Go to:
  2. Find Prime 4 under Standalone DJ Systems
  3. Find Firmware version v1.3.3 and use that to downgrade the firmware.

USBs should be recording fine now.