External SSD not being detected by Prime 4

Hi all,

I have 2 external SSDs that are identical. I have these Labelled DEN 1 SSD & DEN 2 SSD.

As mentioned both are identical and both are formatted to xfat and have worked trouble free for several years. Both work in my laptop and in Engine DJ software on my laptop. Now My DEN 1 SSD is not visible on my Prime 4 however my DEN 2 SSD is working fine. My DEN 1 SSD that is no longer visible worked a few days ago so this is confusing. The SSDs are Samsung QVO top ssds so i refuse to believe one is broken. Is there anything within any settings i can try so my Prime 4 now detects it? The only thing I can think to try is to Format DEN 1 SSD and copy all from DEN 2 SSD hoping that resolves the issues. help required please.

1 Like

Hi Holly, I think you answered your own question, format the SSD and reload to see if it resolves the issue, im not sure there is anything else that can be done outside of that.

Thank you its the only thing i can think of doing ???

Hoped it was something simple as the cloning process takes 2 days ;/

1 Like

The QVO can be slower than a regular HD when writing large data sizes.

They are QLC drives.

The newer QVO’s are a bit better than the previous models (870 vs. 860), but that shouldn’t make a difference in functionality.

Seems like the non-working SSD might have an extra partition that messes things up. However, partitions simply don’t appear mysteriously, so still weird if it worked before.

Like stated, clone the working SSD to the other to solve it.

In case it happens to anyone else. it is now FIXED, I re-formatted and cloned the drive again and now my Prime 4 reads the drive and it is visible again :slight_smile:


This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.